0

my first question on AskDifferent! (let me know if I'm doing it wrong.) Anyway, I'm trying to install octave using brew and am getting the following error but unsure how to proceed:

 ~/ brew install octave
==> Installing octave dependency: cmake ==> Downloading https://downloads.sf.net/project/machomebrew/Bottles/cmake-2.8.7

################################################################## 100.0%

Error: SHA1 mismatch Expected: f218ed64ce6e7a5d3670acdd6a18e5ed95421d1f Got: 3a57f6f44186e0dba34ef8b8fb4a9047e9e5d8a3 Archive: /Users/Billy/Library/Caches/Homebrew/cmake-2.8.7.bottle.tar.gz (To retry an incomplete download, remove the file above.)

 ~/

Any help would be greatly appreciated.

Best, B

  • Tried to tag with octave but it wouldn't let me. – chasingtheflow Mar 16 '12 at 0:17
2

You seemingly have a bad download in the cache. Do this:

rm /Users/Billy/Library/Caches/Homebrew/cmake-2.8.7.bottle.tar.gz

And then try again. Make sure you're up-to-date first: brew update.

  • I actually already tried that before I posted and just ended up with the same error ... Thanks though edit: missed your note to brew update, had completely overlooked that ... trying again. will get back if it succeeds. – chasingtheflow Mar 16 '12 at 0:34
  • ah the sweet taste of success. hat tip to you sir. – chasingtheflow Mar 16 '12 at 0:39
  • I think one of our maintainers changed the file keeping its filename the same. So this error can occur. I apologise. – mxcl Mar 16 '12 at 0:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .