I got a new MBP M1 2021 edition 16GB MEM/ 500GB HDD, migrated using the Migration tool everything from my old MBP (an Intel 2018 one, also 16GB MEM/ 500GB HDD) everything worked (except the Intel apps), wi-fi worked but no internet.

I tried several DNSes, rebooting my Mac, rebooting the router, etc.

Then I rebooted in safe mode and internet did work. But in 'normal' mode internet did not work. Even pinging to internal addresses (including the router) did not work.

Maybe an Intel based service which does not work in M1 might be in the way, but I cannot find anything.

Both run Monterey 12.2.

Any ideas on this ?

  • 1
    Do you have any VPN software installed? I would be tempted to go into System Preferences > Network and remove your primary network service (listed on the left) reboot and add it back in. Mar 10, 2022 at 21:37

1 Answer 1


After more searching I found the problem. It was a Radio Silence per-app firewall, when I disabled it, internet did work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .