0

My company recently upgraded my laptop to OS X Lion and was pre-installed with iPhoto purchased under a different Apple ID. I have my own purchased version so wanted to update the app, but it asked for the other user's password.

So I decided to uninstall the app using Launchpad and try downloading it again. However, when I go to it in the Mac App Store, the button now says "ACCEPT" and when I click on it, I get this message:

These apps cannot be accepted on this computer. Future updates of these apps can be found through Software Update.

What can I do to get iPhoto to download again?

1

I ran into the same problem and finally found the following solution on the apple support forums that worked for me:

  1. Launch App Store
  2. Click the "Purchases" tab (the price-tag icon at the top of the App Store window)
  3. Find iMovie in the list
  4. Click its "INSTALL" button
  • Nice one thanks! I forgot to return here to answer the question... After contacting Apple email support, they told me to do this. I can't believe I missed the Purchases tab! Having said that, it seems a bit silly that the App Store doesn't suggest you do this or do it automatically itself! – Jowie Apr 5 '12 at 8:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .