When I try disable my root user using Directory Utility/Terminal it doesn't disable. When I enter:

dsenableroot -d

it just returns "Failed to disable root user".

Not sure what on earth is going on, can't log into the user either.

  • How did you enable root. By default it is not enabled/
    – mmmmmm
    Mar 4, 2022 at 7:48
  • Are you sure it is actually enabled? unix.stackexchange.com/questions/232491/…
    – benwiggy
    Mar 4, 2022 at 9:15
  • Yeah it’s enabled, when I run the command in terminal to enable it it fails also… so yeah Mar 5, 2022 at 8:16
  • FWIW, my M1 returns "successfully disabled root user" when I run the command. Can you think of anything that you might have done to affect anything like this? E.g. Did you restore a cloned disk image of the disk? Have you tried running the command from Recovery?
    – benwiggy
    Mar 5, 2022 at 13:05

1 Answer 1


sudo dsenableroot -d worked for me, asking for the root password one last time after the sudo authentication.

dsenableroot:: ***Successfully disabled root user.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .