1

Using macOS 12.2.1 on a MacBook Pro M1 while connected to an external monitor breaks sleep mode. On Linux / Windows I expect the sleep mode to power off both my laptop screen and my external monitor by default (plus setting the device into sleep mode).

With this Mac, however, either closing the lid or manually selecting "Sleep" while connected via HDMI to the external Monitor prevents the device to actually switch modes.

Even more, when closing the lid I can still use the mouse and keyboard on the external display, which is not only annoying but also when in an office can lead to privacy issues. The device is not automatically locked after closing the lid and having the monitor connected.

So far the only solutions I've found are:

  • shutting down the device
  • disconnecting from the external monitor before closing the lid / going to sleep mode None of them are ideal, so I'm wondering if someone run into the same issue and found a solution.

The monitor is a LG 27UK670, and I'm connecting to the right side HDMI port.

4
  • manually putting to sleep should work. However, closing the lid puts it in clamshell mode and it is intended behavior that the external screen stays on.
    – X_841
    Commented Mar 3, 2022 at 20:12
  • I can confirm both screens turn off when manually putting to sleep. But the device doesn't really switch modes; moving the mouse / slightly touching the trackpad after putting it to sleep awake the computer where it was at, without even asking to unlock it.
    – Erwol
    Commented Mar 4, 2022 at 7:49
  • You can solve that problem by lowering the time after your MacBook locks. Head over to settings app, security and general.
    – X_841
    Commented Mar 4, 2022 at 17:26
  • Monitor what events are happening on any action. You should be able to programmatically do this. There are some programs which do certain things like this: objective-see.org/products/dnd.html. Perhaps this could be a starting point Commented Sep 6, 2022 at 10:08

1 Answer 1

0

Probably the power cable must have been connected. If it's not connected, the clamshell mode usually doesn't kick in.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .