2

The Software Updates in System Preferences are all disabled. In spite of this macOS continues to show Notification Banners in Catalina (and Big Sur) which some users accidentally click to initiate an update. I want to stop macOS from showing all the Software Update notification banners to prevent accidental updates. Yet I still want to be able to manually initiate software updates when desired.

Previously the following has been suggested:

  1. softwareupdate --ignore “macOS Big Sur”, but this is not available any more as a command option and would block only major upgrades not minor or security upgrades AFAIK. (Only available in High Sierra up to Catalina with Apple Business Manager enrollment, Apple School Manager enrollment or Enrollment in a user-approved MDM)

  2. Moving com.apple.SoftwareUpdateNotificationManager.plist from /System/Library/LaunchAgents to /System/Library/LaunchAgentsIgnored, but in order to make these changes, one must boot from another disk, otherwise System is read only. Also the notification will reappear if Software Updates is selected in System Preferences. This is cumbersome as it means a lot of steps including additional reboots when updates are desired and manually initiated.

I am currently testing another proposed solution which is to install the Lulu application firewall and then to block /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated.

Blocking and re-enabling softwareupdated for manual updates would be less cumbersome than disabling and re-enabling the system protected LaunchAgent, but I am not quite sure, if it will actually prevent the notifications from appearing. Who can confirm that this works in the long run?

Are there any other options to accomplish this?

Related questions: How to block updates to Mac OS X Catalina? / Remove macOS Big Sur "Upgrade Now" button in System Preferences / How can I permanently disable App Store notifications in Big Sur?

1 Answer 1

0

I have now tested blocking softwareupdated for a few weeks and it works as intended. - This has recently become even more important, since the Monterey update from 12.2.1 to 12.3 has caused serious issues with AMD 5000 and 6000 series graphics cards for many users.

TL;DR

The short answer is to install the LuLu Application Firewall and block the process softwareupdated when prompted. Re-enable it temporarily when you want to do manual updates.

Detailed Step-by-Step

The obvious first step is to completely disable all updates in System Preferences, but surprisingly this alone does not stop the clickable notifications.

Download and Install Lulu

Objective-See: LuLu Application Firewall - Big Sur is recommended for version 2.4. Also available is version 1.2 for older macOS versions.

Initially enable all firewall prompts

  • Lulu Preferences > Rules > Uncheck All, so that you will see all Firewall prompts initially.

Trigger a Software Update Request

  • System Preferences > Software Updates > Advanced change any update setting to trigger a software update request

  • Block when asked

    • Creates a new firewall rule

Disable Software Updates

  • In System Preferences > Software Updates > Advanced - make sure that all software update settings are set to disabled

  • Wait for the timeout

Manually Check for App Updates and/or macOS Updates

  • In Lulu > Rules search for softwareupdated and temporarily allow software updates
  • Double click on the rule and change to Allow

Enable Software Updates Temporarily

  • System Preferences > Software Updates > Advanced activate the items you wish to update

Reenable the Firewall Rule blocking Software Updates

  • In Lulu > Rules search for softwareupdated and block software updates again
  • Double click on the rule and change to Block

Disable Software Updates Again

  • System Preferences > Software Updates > Advanced deactivate all automatic updates again

Note: this method may still not be idiot proof if a user uses System Preferences directly: I have seen the Monterey 12.3 Software Update actually re-appear inside System Preferences after a while in spite of software updates being blocked by the firewall. This may be due to initial caching of the update information.

See also my article: Block Update Notifications - Guide with Screenshots

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .