0

I'm using a USB ANSI keyboard and I've tried this with several keyboards so I'm reasonably confident it's not keyboard hardware at issue.

Using text applications, as in iTerm or Ulysses, everything is fine. Checking the keyboard via od -a, SPACE TAB NEWLINE gives

[chasrmartin] 1223 $ cat | od -a

0000000   sp  ht  nl
0000003

In some GUI applications, like emacs, Brave, and Chrome, the keys are mapped to something else. In EMACS CMD-X should be M-x, but it's actually H-x; the spacebar isn't a space character but instead is some mystery character that is mapped to <tool-bar><open-file>.

In Twitter, some number of tweets work fine; then it no longer recognizes the space bar at all, soeverythingcomesoutlikethis.

I've tried different keyboards, as I mentioned. I've done the new keyboard process to no avail. I have reset the NVRAM — or at least I think I have as there is little feedback to indicate success.

I'm frankly kind of at wit's end. I'd rather not reinstall the OS but that's the only other idea I've got.

Help?

UPDATE

Just to be clear, this is happening in many — but not all — GUI applications. The Twitter example is accessing Twitter through Chrome. On the other hand, Firefox doesn't have the problem.

4
  • Emacs does remap keys so depends on your init files <f1>k then press they key will show what it is mapped to.
    – mmmmmm
    Commented Mar 3, 2022 at 7:57
  • It's not just emacs. See the part about twitter? Commented Mar 3, 2022 at 15:34
  • Yes that is why I made it a comment and not an answer
    – mmmmmm
    Commented Mar 3, 2022 at 15:41
  • Yeah, I didn't notice that SO had suppressed my showing what the EMACS key mapping was. Commented Mar 3, 2022 at 16:04

1 Answer 1

1

After an amazingly helpful talk with Apple support, I found the problem and a workaround: I turned off Accessibility > Keyboard > Enable Full Keyboard Access

Screenshot of Accessibility Preference Pane with. Keyboard section selected on the left pane, Navigation Tab selected in the right pane, and Enable Full Keyboard Access checked

Screenshot of Accessibility Preference Pane with. Keyboard section selected on the left pane, Navigation Tab selected in the right pane, and Enable Full Keyboard Access unchecked

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .