8

I have a MacBook Pro (15-inch, Early 2008) that's currently running 10.7.3. I've been finding that it will intermittently freeze and then I have to shut down and restart the computer, but sometimes that will not fix the problem.

If I plug in an external mouse and keyboard, then I can move the cursor and type again, but as soon as I remove them, the problem persists.

I've tried resetting the P-RAM, reinstalling Lion, installing a new HD, and I've had the graphics chip tested and it's performing properly. If you have any suggestions on how to fix or diagnose, that would be very helpful. Thank you.

8
  • 1
    Upgrading to 10.7.4 might help.
    – lhf
    Sep 3, 2012 at 20:14
  • Same bug happening sometime with Mountain Lion
    – Luigi
    Feb 13, 2013 at 23:23
  • 1
    I have the same issue with 2018 MBP and Catalina. Annoying! Nov 22, 2019 at 13:36
  • 1
    @AntonStrogonoff I have the same issue. Might be related to running VmWare fusion vms
    – jontro
    Dec 9, 2019 at 22:42
  • @jontro It does correlate, since I haven’t been running VMs for about a month and that issue stopped happening as well. Thank you for the observation, I didn’t make the connection Dec 11, 2019 at 1:22

3 Answers 3

1

So, correct me if I'm wrong, your problem occurs when you open your MacBook Pro?

Resetting your PRAM won't work. Try resetting your SMC. This is responsible for the responses when opening and closing your lid.

5
  • The problem can occur even if the lid is left open, which would be the case during a restart. And sometimes it becomes unresponsive while using the computer. Nonetheless, I haven't tried resetting the SMC and will give it a try. Good suggestion, Michiel, thank you. For the record I've also tried turning off Spotlight indexing and that didn't fix anything either.
    – Brian K.
    Mar 16, 2012 at 21:22
  • Ok, great. Let me know how it went!
    – Michiel
    Mar 17, 2012 at 11:09
  • Resetting the SMC didn't fix the problem either
    – Brian K.
    Mar 17, 2012 at 14:20
  • Just to review, here's everything I've tried: - Reset PRAM - Reset SMC - Disable Spotlight indexing - Re-install OS - Use a different Hard Drive - Tested the graphics chip for defects - Ran a permissions repair
    – Brian K.
    Mar 20, 2012 at 21:42
  • Was it a clean reinstall? Have you tried booting it in safe mode?
    – daviewales
    Dec 4, 2012 at 13:16
0

Resetting the SMC should fix the issue. Note that this will reboot the MacBook, so you will lose any unsaved work.

  • Shut down the computer.
  • Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.
  • On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time.
  • Release all the keys and the power button at the same time.
  • Press the power button to turn on the computer.

Note: The LED on the MagSafe power adapter may change states or temporarily turn off when you reset the SMC

1
  • 2
    This answer is copyed and pasted from another AD question and did not solve the issue in both cases.
    – MaxPowers
    Mar 4, 2018 at 6:13
-1

I had this same problem.

Installing OS X 10.9 Mavericks resolved it for me.

2
  • I still experiencing this issue on 10.9.2.
    – Laszlo
    Apr 25, 2014 at 9:23
  • 10.10 also with 2015 13 mbp retina
    – Christoph
    Dec 20, 2016 at 10:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .