0

Terminal.app's window size always fit the rows and columns of its content, which make it impossible to maximize the window (always leaving a gap).

pic

I know iterm.app has an option regarding this. Can I change this behavior in terminal.app too?

6
  • 1
    What exactly is your question here? And what is shown by the picture/screenshot? Please edit the question to add details.
    – nohillside
    Commented Feb 28, 2022 at 15:08
  • 1
    After your edit - do you actually mean fullscreen, or maximised? Dragging would imply maximised. Double-clicking the corner when the cursor changes to a double arrow should maximise as far as the window will go. There will always be a small gap at the bottom, reserved for activating the Dock.
    – Tetsujin
    Commented Feb 28, 2022 at 15:23
  • @Tets I hide my dock, it's an issue specific to terminal, other apps like chrome don't behave like this. AFAIK iterm and emacs also have this behavior, more like a feature. but you can turn them off (superuser.com/questions/581889 stackoverflow.com/questions/27758800), I want to know if it
    – nichijou
    Commented Feb 28, 2022 at 15:38
  • is possible to turn this behavior off in terminal.app
    – nichijou
    Commented Feb 28, 2022 at 15:39
  • It resizes in increments of character rows and columns, not arbitrary pixels. Commented Mar 1, 2022 at 0:22

1 Answer 1

2

Terminal.app resizes in (character) rows and columns, not in pixels. There is (at least up to and including macOS Monterey) no option to change this.

1
  • well, that's a bummer. thanks for your information.
    – nichijou
    Commented Mar 1, 2022 at 14:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .