I'm running Mac OS X (think it's Snow Leopard - 10.6.7) on a Mac mini. I'm trying to connect remotely from an iMac (this has been working fine in the past, for some time). When I click "Share Screen..." in finder on the iMac, I (eventually) see the server's desktop, but it appears to be frozen. However, I've managed to determine (from closing the window and sharing screen again, on repeat) that it IS actually receiving input, just not updating the display.

I can ssh into the server, but how can I restart the screen sharing service?


I had the same trouble, and to a headless Mini also. This is what I found that worked…

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.screensharing.plist  
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.screensharing.plist

I had the opportunity to install an SSD in my Mini, and did a clean install of Lion at that time, and the issue persisted.

I made an alias

alias fixscreen='sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.screensharing.plist &&  sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.screensharing.plist'
  • Thanks for this solution, was looking for it already for years! – t0r0X Nov 2 '14 at 19:41
  • Of course, you need ssh enabled on the server. – Greg Glockner Nov 9 '15 at 15:35
  • 1
    Works in MacOS High Sierra A+ 💯 – dps Dec 11 '17 at 18:28
  • Just tried this on High Sierra (10.13.5) and it worked like a charm. – Markus Amalthea Magnuson Jul 7 '18 at 22:09

OK, managed to find the answer (or, at least, an answer; I'm not quite sure on all the details of this command):

$ sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -users admin -privs -all -restart -agent -menu

As always - be careful when you paste something into terminal - best to inspect the command before running it. Doubly so when sudo is involved.

  • I'm not clear about the relationship between ARDAgent (ie remote management) and just screen sharing. The the UI, you can tick Screen Sharing and NOT Remote Management but kickstarting ARDAgent remotely ticks Remote Management and NOT Screen Sharing (although it enables VNC). Does that make sense? – Toby Sep 29 '12 at 13:00

Using launchctl unload and launchctl load still works but the commands are now "legacy commands".

Here's a more recent approach that also works with a single command:

sudo launchctl kill KILL system/com.apple.screensharing

This instructs launchctl to kill the screensharing service and then launchctl automatically restarts it after it has exited.

  • Does that work on Snow Leopard, as the question asks about? – tubedogg Oct 26 '16 at 21:17
  • No, it doesn't work in Snow Leopard: "Unknown subcommand 'kill'"! – awado Jan 23 '17 at 11:28

Rather than restart just the screen sharing service, I would suggest remote restarting the Mac Mini. You can do this via SSH by typing in:

sudo shutdown -r now

This will not only restart the screen sharing service, but may also resolve the issue that caused it to act up in the first place.

  • Sometimes you need to use the big hammer. It is a valid tool and should not be downvoted just because it is not subtle. In my case to regain access to a remote login I had to restart the whole machine to clean up a failed icloud setup wizard. – BitByteDog Mar 2 at 2:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .