1

I had to rename my user and home folder recently, but did it according to the official guide from Apple. Initially, all icons in the sidebar of Finder appeared as a generic folder. Removing and re-adding them fixed the issue for all icons, except the Desktop icon.

enter image description here enter image description here

What I've tried/checked

  • The account name and home folder name are the same (also in cAsE)
  • The home folder is set correctly for the account
  • I've rebooted
  • I've rebooted in safe mode
  • I've cleared the PRAM

Did anyone run into the same issue yet and was able to fix it? Running macOS 12.2.1 on a 16-inch 2021 MacBook Pro.

4
  • Un-check "Desktop" (as in your first image) then navigate to your user folder. There should be a folder there called "Desktop." Drag it into the sidebar. Does that fix it? Feb 22 at 18:58
  • @SteveChambers Good suggestion, but sadly that's having the same result.
    – Double M
    Feb 24 at 14:36
  • Since deleting the icon cache didn't work, my next suggestion would be to use a program like Onyx or TinkerToolSystem to delete all user and System caches. Also, delete the com.apple.finder.plist and reboot. And finally, if that doesn't work, boot into Recovery Mode and reset the home folder permissions.
    – Jonesy
    Feb 24 at 23:17
  • @Jonesy Thanks so much for your effort. I've tried all your (really good) suggestions, but none of them did the trick. I've even ended up reinstalling macOS altogether and restoring from a backup before I renamed the user, and the problem still persists. Now I have decided it's no longer worth pursuing.
    – Double M
    Feb 26 at 14:54

2 Answers 2

1

I was having the exact same problem as yourself, every icon except the desktop icon showed correctly. I tried all the recommendations above and none of them worked for me either.

However I did manage to fix this is the end.

Under iCloud Drive, I enabled the Desktop & Documents folder. This will cause the Desktop and Documents sidebar icons to move underneath the iCloud section instead of Favourites. Once they have moved, you will need to drag the Desktop and Documents icons back up into the Favourites section.

Once all this is done you can disable the Documents and Desktop folders in iCloud Drive and the icon issue should be fixed.

0

Have you tried cleaning the Icon Services cache?

https://mjtsai.com/blog/2019/02/01/clearing-the-icon-services-cache-in-mojave/

https://eclecticlight.co/2019/01/30/why-doesnt-that-documents-icon-display-properly-beyond-quicklook/

2
  • Great resources, thanks. Strangely that also didn't help. It's driving me crazy.
    – Double M
    Feb 24 at 14:52
  • I have no idea how or why, but after a few days it all of a sudden reverted back to the correct icon on its own. Maybe one of your tricks helped after all :) cheers!
    – Double M
    Feb 28 at 12:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .