3

Intro

I've got a headscratcher with my camera setup on macOS Monterey. I go back and forth between using an external webcam (a Logitech C615) and the internal FaceTime camera on my MacBook Pro. I've had zero issues for the entire time I've had the laptop. A week ago, I updated to Monterey from Catalina, and now both cameras are behaving very strangely.

The problem

First, the actual camera functionality on the webcam failed, but the laptop still detects it as a microphone. I tried plugging in the webcam through docks, directly via a USB-C->A dongle, etc., and it did not work. I figured the camera had died, so I bought a brand new one and it did not work either. However, I noticed something very weird when I plugged in the new camera. If I open FaceTime with no webcam plugged in, I can see that the internal camera works. However, as soon as I plug in the external camera, the internal camera fails to be detected with the message "no camera connected", and of course the webcam does not work either. FaceTime can see the microphone on the webcam but suddenly does not recognize the internal MacBook Pro camera or the external one. ~50% of the time, restarting FaceTime after unplugging the camera works and restores the internal camera. Sometimes, it requires a reboot.

What I've tried

As described above, I tried every dongle/direct plug I had, as well as trying a new webcam. I manually stopped and restarted the video controller via sudo killall VDCAssistant. I've reset the PRAM and the SMC. I've booted into Safe Mode and replicated the problem there. I fully updated macOS to the latest version (12.2.1) and updated all of the component software. I tried to reinstall macOS via Recovery Mode, but was unable to connect to the Internet for some reason and was unable to complete the update. I've tried installing ManyCam per the solution in this StackExchange question which did not work.

Any ideas on what might be causing this? What should I do from here? Please let me know if there is any other info I can provide, either about the system or the webcam.

1 Answer 1

2

Try updating to macOS 12.3.1. I have heard reports of some USB cameras working better with the update.

3
  • Thanks @Matthew! Will do, and I'll update (and mark as correct) if this worked. I've been afraid to update because updating from Catalina is how I got in this mess :) Commented Apr 4, 2022 at 21:15
  • Same thing happened to me! The Monterey upgrade completely screwed up my Logitech 922 camera. I tried a bunch of things and opened a ticket with logitech. Apparently it's a known issue with Logitech and there is no fix yet. I'm on Mac OS 12.3.1 and no fix for me. Did you ever resolve? Commented Jun 14, 2022 at 15:31
  • Just popping back in to confirm this worked! Thanks Matt :) Commented Aug 5, 2022 at 1:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .