I have an iPad that is having issues during a factory reset. I start the process by plugging it into my Mac while the iPad is powering up so that it enters Recovery mode.

Once in Recovery Mode, I see a prompt that says 'There is a problem with the iPad "iPad" that requires it to be updated or restored'. I click "Update" and after some time, I get another prompt that says 'If your iPad can't be updated, you will need to restore it to its factory settings'. I click "Update" again, after which Finder says the update is being downloaded.

About two minutes later, I see an error dialog box with the text 'The iPad "iPad" could not be updated. An unknown error occurred (4041)'.

See the bottom of my question for screenshots.

I would like to note some context: my friend works for [large-tech-company] and was lent this device for their work. The device has no access to corporate resources (no MDM installed, only iCloud AFAIK). I asked said friend if I could borrow the device to try it out; they said yes but also that they forgot their password. Hence, I tried using a factory reset.

How can I fix this? I can't get it back to a working state. I am hesitant to bring this to an Apple store as they may report the device as stolen to [large-tech-company], which could cause me more trouble than if I just explained it to my friend. I don't see any option other than explaining to my friend that I broke their device and that they need to explain this to their employer.

I feel really dumb for thinking a factory reset would have worked, surely [large-tech-company] has a deal with Apple to ship a custom OS for employees (my friend opened the iPad from its box which is why I thought there wasn't an issue with factory reset). I also realize that there is nothing in my story that differentiates me from someone who has stolen a company device and is trying to restore it to prepare it to be sold. So if you don't feel comfortable helping, then I understand.

Technical notes:

  • My Mac is running macOS 12.2.1.
  • I used two different USB-C cables, with the same result.
  • Clicking "Restore" instead of "Update" causes the same issue.
  • After I get the 4041 error, Finder is no longer able to try the update again (it just gets stuck at a loading page). Killing the process doesn't help; the only way to retry the whole process is to restart my Mac.


The iPad "iPad" could not be updated. An unknown error occurred (4041)

If your iPad can't be updated, you will need to restore it to its factory settings

There is a problem with the iPad "iPad" that requires it to be updated or restored

3 Answers 3


Had the same error message while trying to do factory reset on an iPad, third (!) cable I tried finally worked.


I have the same problem and tried three different cables. The last one worked for a while but I got stuck on loading. I managed to proceed with the update later but it failed again.

In the end, it looks like it was more related to a loose connection in the iPad's port as it helped me to hold the iPad in the air so nothing was pushing the lightning connector up (in the opposite of the situation when the iPad is laying on the flat surface as the lightning connector is thicker than the iPad)


Use a type-A to lighting cable

Exactly the same error and resolved finally, after many many retries.

Apple had cut off USB type-A long time ago. So I use a type-c to lighting cable naturally.

After countless failures & retries, I realized this cable is actually my iphone cable, my ipad is pretty old it sells with a type-A cable.

Use a type-A cable and an type-c/type-a converter, problem solved.

Hope this can help you too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .