11

I used to get desktop notifications for Google Calendar running in Chrome.

This is very useful to help me not to forget to join a Zoom meeting when working from home.

But for a while now I have not been receiving them.

I have my notifications settings in Google Calendar set like this:

screenshot

I hear the sound but I don't get a desktop notification.

1 Answer 1

12

It turns out Chrome did not have notifications enabled in macos settings:

screenshot

(not sure why I have two Google Chromes in this list)

Enabling this fixed it:

screenshot

3
  • 1
    I had been changing notification settings for the Calendar app, not for Google Chrome. I have two Google Chromes, too; I'm suspecting that's because I'm using two Chrome profiles.
    – Noel Yap
    Commented Sep 6, 2022 at 18:50
  • "I'm suspecting that's because I'm using two Chrome profiles" ...that sounds quite likely, I also have two Chrome profiles (it's a shame we can't distinguish which is which in macOS settings though!)
    – Anentropic
    Commented Jan 12 at 10:45
  • I had to enable notifications for Google Chrome Helper (Alerts) as well to get it to work as expected. stackoverflow.com/a/75804760/2113226 Commented Mar 27 at 18:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .