4

I connect my Mac to my Dell monitor with a ThunderBolt3/USB-C cable and it used to charge before. Now when I connect it shows the charging sign on my battery but says the following.

enter image description here

What has gone wrong here? I tried connecting two of my Macs and both behave the same way. I tried restarting and that too didn't help. Would appreciate any help/advice.

PS: I did try to connect both my Macs using this Thunderbolt cable for data transfer once, and this issue started happening almost after that. I disabled file transfer option just in case, still no luck.

3
  • Do you have adaptive charging enabled? - Have you tried letting it sit like this for a while to see if it starts charging after a while?
    – jksoegaard
    Feb 8, 2022 at 10:17
  • I disabled "optimized battery charging" but its still not charging. I have left it sit like this for a while, but it went to 0% and Mac turned off :(
    – AnOldSoul
    Feb 8, 2022 at 21:37
  • Do you have another cable to test with? - The cable could be damaged?
    – jksoegaard
    Feb 8, 2022 at 21:41

1 Answer 1

1

I realise this is an old question, so probably not helpful.

But I also ran into this problem specifically after using the same cable for Mac -> Mac migration assistant, it no longer charged from Monitor.

The M1 Macs do not have SMC, but the equivalent is shutting down laptop for at least 30 seconds. After doing this it charges as it should.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .