Earlier today I had an issue with an extension not showing up in Safari. In a desperate attempt, I ran the following command:

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

Immediately after that command ran, Safari became unresponsive. In particular, I am facing the following issues:

  • The start-up time is very large (i.e., 35 seconds or more)
  • The beachball appears when right-clicking a link on a webpage. Then, it takes roughly three seconds for the context menu to appear.

It is clear to me that lsregister did something, and my question is what exactly did it do and how can I reverse it? I am running macOS Monterey 12.2.

  • Does rebooting fix it?
    – lhf
    Feb 4, 2022 at 16:56
  • @lhf Sadly no, I tried that. Neither booting into Safe Mode.
    – Mihai
    Feb 4, 2022 at 16:58
  • So reinstall macOS.
    – lhf
    Feb 4, 2022 at 17:01
  • I do suspect the issues to be link-related because when I open Safari it takes some time to render the home page where all the Readings links are present. Then, a similar lag occurs when right-clicking a link.
    – Mihai
    Feb 4, 2022 at 17:02
  • @lhf I am hoping for something less dramatic than a reinstall.
    – Mihai
    Feb 4, 2022 at 17:03

2 Answers 2


For me emptying the safari cache worked: Safari -> Develop -> Empty Caches

Restarted and right click no longer has a delay


Reset the NVRAM on your Mac

Had the same issue with extensions not showing up. After issuing the command, you mentioned, Safari became hellish slow. Resetting the NVRAM solved it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .