42

Is it possible to permanently disable all keyboard shortcuts that toggle the "Enable Dictation" dialog in Monterey? In previous versions of macOS, the dialog had a "Don't Ask Again" button, but that's no longer the case:

Enable Dictation dialog

Furthermore, the option to change the keyboard shortcut to "Off" is gone from Settings:

Shortcut options

0

5 Answers 5

41

I have MacOS Monterey 12.2 and can turn off the Dictation shortcut (System Preferences > Keyboard > Dictation > Shortcut):

Dictation Shortcut: Off

In MacOS 13 Ventura it's located in System Settings > Keyboard > Dictation > Shortcut > select "Off".

enter image description here

For some systems the following is true:

In Mac OS 13 Ventura, the "Off" option has been removed. The closest option to that is Press 🎙️

Dictation Shortcut: Press 🎙️

5
  • I wonder if it has to do with the model of device instead. Does your device's keyboard have a built-in "Dictation" key that looks like a microphone icon? Mine does.
    – Zenexer
    Feb 5, 2022 at 22:42
  • 14
    Oddy, on my M1 MBP running Monterey 12.2.1, Off isn't even an option, in it's place is Press 🎙 which I've selected instead and will still probably be better than the default.
    – Cory Klein
    Apr 14, 2022 at 15:05
  • 6
    can confirm that Press🎙 is better than the default. Not sure what that key actually is, which is sort of the point.
    – ijoseph
    Aug 22, 2022 at 18:48
  • Thankyou lord! I can't tell you how many times this thing has popped up by accident over the years. Finally getting rid of it.
    – user415092
    Dec 12, 2022 at 21:16
  • I notice this doesn't change the default behavior on the lock screen. When set to Press🎙 and logged in I can smash the ctrl key without dictation turning on. However at the lock screen I hit ctrl a bunch of times to wake the computer, and once i'm logged in sure enough the "Enable Dictation?" dialog has appeared on Sonoma 14.1.1
    – xref
    Dec 13, 2023 at 21:49
8

This was bothering me too, while there's no way to disable the keyboard shortcut entirely. You can fairly easily set it to a combination of keys that you'll never press again. Such as three modifier keys at once followed by slash

enter image description here

2
  • 4
    Doesn't work for me on Ventura. Whatever the shortcut I set, the popup still comes up when I press the microphone button (F5).
    – Guillaume
    Mar 1, 2023 at 9:53
  • This is also the solution for Sonoma (Mac OS 14)
    – ratbum
    Oct 20, 2023 at 8:30
3

I also find this really annoying on my new MacBook Air. The only way I found out to stop accidental hits (happens for me especially when hitting F5 to build a LaTeX document in visual studio code / texlab) is to check System Settings -> Keyboard -> Keyboard -> Use F1, F2, etc. keys as standard function keys. This means that accessing volume, play, etc., buttons is a bit more clumsy, requiring holding down Fn, but at least accidental hits of the useless dictation key are gone.

2
  • 1
    Seems to be bug, but this actually appears to completely disable the search, dictation, and do not disturb keys that I didn't have on my previous mac. They no longer work even with Fn. The other media keys work behind Fn, but these don't. Feb 8, 2022 at 8:58
  • This seems to be the only option in Mac OS 13 Ventura. Customizing the keyboard shortcut (as suggested in other answers) does not disable the dictation key (F5). Jul 24, 2023 at 15:20
1

If your goal is to just disable this Keyenter image description here

You can do that by installing Karabiner-Elements

Just assign that key to VK_None to disable it entirely, or you can reclaim it to F5, or any other shortcut.

enter image description here

1
  • Excellent, tx, the only fix for me on MacOS 14 Sonoma :/ Also replaces the now defunct FunctionFlip! 👍
    – ptim
    Feb 5 at 4:46
0

You can make the icon go away by turning off the Voice Over feature in Accessibility:

  1. System Preferences > Accessibility
  2. On the left, scroll down to the "Motor" section, then select Voice Control
  3. Deselect Enable Voice Control

Screenshot of the Accessibility Preferences Pane showing the Voice Control options

1
  • Thanks, but that's not what I'm trying to do. I already have that turned off. I'm trying to disable all keyboard shortcuts that prompt to turn Voice Control on when it's currently off.
    – Zenexer
    Nov 2, 2022 at 12:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .