For some reason, macOS Mail on Monterey will display remote content for messages in the Spam folder of both my Gmail and Exchange accounts. This is of course unfortunate because the spammer then knows the message sent to me has been opened, hence that my address is valid. I’ve been receiving tens of messages a day (even more than a hundred on some days) for the past months, and I suspect this plays a part in this.

I’ve tried enabling Junk Filtering in Mail — as recommended somewhere else on SE — to no avail. Mail stubbornly displays remote content in both Junk folders.

The only option that definitely works is the one to "disable loading all remote content", but then of course on every mail I’m receiving I have to click on the "show remote content" button, which is annoying.

How can I prevent macOS Mail from displaying remote content for junk mail — as should be the sensible thing to do?

  • If there is no answer to this question, one recourse is to file 'feedback' with Apple to register your concern. According to the blurb on the page, all submissions are read carefully, and Apple may contact you for more information if you provide your email address.
    – IconDaemon
    Feb 2, 2022 at 16:25
  • Agree this would be useful. I personally review my junk mail in gmail for this reason. I also do it in gmail to ensure I’m teaching the spam filter when I mark/unmark spam - not sure that doing this in Mail has the same effect.
    – JBallin
    Feb 2, 2022 at 20:31


You must log in to answer this question.

Browse other questions tagged .