I have an iPhone 4 (Verizon, Model MD146LL) and I just upgraded from iOS 5.0.1 to iOS 5.1 (9B176) using Settings > General > Software Update.

Immediately after completing the update, I noticed that my phone did not make the unlock sound as I unlocked my phone. "Oh, the volume must be down", I thought. So, I made sure my mute switch was off and pressed the + button to increase the volume. Unfortunately, I was greeted by the empty ringer volume popup:


"Apple must have changed the default setting for the volume buttons ^^"... Surely, I could change it myself! So, I head over to Settings > Sounds:


Oh, the settings are right. Hmm... What happens if I move the volume slider?

Rejoice! MARIMBA!

Ok, so my phone can play audio. Can it play music or watch a video?




video 1


video 2

Other controls:



Hoping that this was just a temporary glitch, I tried the following:

  • Switching Change with buttons on and off
  • Turning my phone on and off
  • Hard reset (holding Home+Lock until it reboots)
  • Plugging and unplugging my earphones
  • Plugging and unplugging the USB charging cable

Plugging and unplugging the USB cable seems to fix the issue. However, as soon as I lock the phone, the sound and volume controls are disabled again! Due to this behavior, I'm convinced that this is a software bug and not hardware related (e.g. faulty headphone jack).

Has anyone else experienced this? I'm afraid I'm going to have to do a clean restore or downgrade back to iOS 5.0.

Update 1:

Settings > General > Reset > Erase All Content and Settings was unsuccessful, even when setting up the phone as a new device (no backup). The bug is still present. I will be trying a clean restore from iTunes soon.

Update 2:

Restoring as a new device using iTunes was also unsuccessful. :( From my research, it looks like this bug not specific to my model:

Update 3:

After further analysis and comparison, I think that this bug is related to the External Accessory Framework (or similar components). When you are plugged into a compatible device, the controls are hidden, similar to my screenshots above. This may also explain why plugging and unplugging the charger temporarily fixes the problem. "I'm unplugged; I should enable my volume controls now."

  • I have been having the same problem as well. I have basically tried everything you have mentioned above and I got the same results. In every forum you check they will clean the dock and stuff and nothing more. I have tried that and it was never dirty in the first place. I cleaned it again and still nothing.
    – user20432
    Mar 20, 2012 at 14:43

1 Answer 1


From the fact that the issue persists across multiple firmware updates, it's almost definitely a hardware or firmware issue.

My first guess would be some small amount of metallic debris in the dock connector. It's likely that connecting and disconnecting the usb connection forces the software to assume that there is nothing connected, until the next time the phone wakes, when it checks if it's connected to a passive audio-out adapter.

Some metallic debris in the dock connector could force the phone into thinking there is always a line-out adapter present.

Try cleaning the dock connector with compressed air or a soft brush, or look into it with bright light to see if there are any bent pins.

  • I cleaned the dock connector, and the issue was still there after a hard reset. So, I tried a full restore one last time, and it worked! ... So, I don't know what to say. If it is a hardware issue, it's strange that dozens of other people experienced that same thing at the same time. It could be that Apple changed something with the dock connector interface that made it "sensitive" and as such, produces a false-positive more easily. *shrugs*
    – iglvzx
    Mar 21, 2012 at 23:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .