1

So I have this same problem:

I purchased two new monitors recently and both had pretty bad overscan (underscan? there were black bars around the screen). My mac no longer has the setting it used to have in the Displays section of System Preferences to fix this.

Here is the solution I had hoped would help: How can I fix underscan/overscan when the slider isn't shown in System Preferences?

Unfortunately /var/db/.com.apple.iokit.graphics does not exist in MacOS Monterey. Trying to find it on Mac, as well as googling around... I have found nothing.

Does anyone know where pcsn values are now kept? Or if there is any solution to manually changing underscan settings without using MacOS' GUI?

2
  • Don't use HDMI. Jan 28 at 20:57
  • I'm using Monterey and /var/db/.com.apple.iokit.graphics exists for me.
    – Cody
    Jan 28 at 21:48

3 Answers 3

2

smithjw was right - found this thread by searching my problem, the solution was to hit "p size" on my monitor's remote to squish things down to fit the sceen. HDMI image was way too big for the screen, mouse going off all four edges. Changing monitor settings fixed it.

I'd rather do it the old way though, underscan, so I could leave the monitor setting to default, no idea what I will plug into it next time.

0

I had the same problem. This is probably an error/bug since I was using my monitor #1 via HDMI with no problems, and then when I plugged monitor #2 into my Mac and played with the underscan/overscan slider to fit everything into monitor #2, then when I go back to the display I always use (monitor #1), it was underscanned and there was no slider to fix it!

As a mac OS Monterey user, I could not find /var/db/.com.apple.iokit.graphics as well.

The problem is weirdly solved by using an HDMI-to-VGA converter and plugging my mac to monitor #1 with VGA, and then switching back to HDMI!

It probably is a bug...

-1

This is likely an issue with the displays themselves. If you have your Mac plugged into the monitor via DisplayPort or HDMI, they will send the full picture/resolution to your monitors.

In order to resolve this, you'll need to use the buttons on the external displays to open the menu and change either the Aspect Ratio or scale.

To get more specific, if you have the model number, simply search Google for "MODEL_NUMBER overscan" or "MODEL_NUMBER aspect ratio".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .