I followed the steps on this stack post and set the shortcut to L on my MacBook Pro (13-inch, M1, 2020)

I can confirm that I see this change in the menu -

enter image description here

However, when I try using this shortcut, it doesn't work! I assumed there might be another function associated with this shortcut already, but I couldn't find anything that uses this shortcut in the keyboard shortcuts menu inside system preferences.

The weird part is, this works on my old macbook (MacBook Pro 13-inch, intel i3, 2017) as well as on my office macbook (MacBook Pro 13-inch, intel i7, 2019)

Am I missing something?

Update: I am not sure how relevant this is, but I was testing if the keys work properly, to begin with https://keyboardchecker.com/

I used the delayed screencapture command to take screenshots while holding the keys down on the keyboard.

I was able to see both the keys being detected individually:

enter image description here

However when I held L it showed "Dead"

enter image description here

I am really not sure what this means, or if it's relevant to this issue, but I thought I would add this for anyone who might find this useful to help me with my question.

3 Answers 3


Try to set shortcut to L Issue might be that when you press your keyboard will change (there will be no "L" or any other letter). You can test it by clicking on a language icon in top right corner (where you see wifi logo, time, bluetooth logo etc) and select Show keyboard viewer Then in keyboard viewer try to press to see how all letters disappear from the keyboard

  • But the Option+L shortcut works on my older mac without any issues. Aug 24, 2022 at 7:38
  • I guess your only chance is to use ShortcutDetective (or similar app) that finds which app is stealing your shortcut irradiatedsoftware.com/labs
    – BorisTB
    Aug 24, 2022 at 7:45
  • No it didnt work. I tried the shortcut detective and it didnt show me any app that is using that as a shortcut. Weirdly enough, it showed something similar to the dead key which I was getting on my other keyboard. Aug 27, 2022 at 0:19

I tried L to "Lock Screen" on my M1 MacBook Pro, it does not work if the current app is System Preferences, but it works when I switch to any other app or quit the System Preferences. Did you tried like this?

  • No, this is in general, not just during systems preferences. Aug 27, 2022 at 0:17

I tried to set it up with the app Shortcuts. It worked.

14 inch, 2021 M1 Pro enter image description here

  • Your screenshot is part of your answer but it is in French. The language for this site is English. Pls either describe the screenshot in English in detail or replace it with an English version.
    – Alper
    Aug 9, 2023 at 9:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .