1

I created an Input Source (Language Keyboard) with Ukelele. It worked fine on my BigSur. Now I moved the file to my new Macbook Pro Monterrey. The same thing happens whether it is on /Library/Keyboard\ Layouts/HebrewYiddish.bundle under root or Home.

When I am in Chrome, Atom, Terminal, System Preferences search box, Pycharm, Zoom, Finder path-field, MacPass, LibreOffice Writer, or Firefox, I can easily switch.

When I am in Whatsapp, Pages, Safari, TextEdit, Reminders, Stickies, or Slack, I cannot. Selecting it in the taskbar just sends me back to another Input Source. Likewise with the ⌃ -Space keyboard shortcut to switch Input Source (which of course pops up the new Monterrey keyboard-switching overlay GUI). If I enable the Input Source in one app and switch to a problematic app, the Input Source changes away instantly when I open the app.

enter image description here

In Settings, it appears correctly regardless, and the keyboard image shows the keys correctly.

enter image description here

How can I keep the Input Source consistently available in all apps?

enter image description here

4
  • The Ukelele group can probably help too: groups.google.com/g/ukelele-users?pli=1 Jan 27, 2022 at 12:47
  • @TomGewecke Indeed, I was using Ctl-Space on an external keyboard. But the same things happens when selecting with the mouse pointer in the GUI.
    – Joshua Fox
    Jan 27, 2022 at 13:34
  • @TomGewecke I moved the bundle, then removed and added the Input source. I will report back on whether that works.
    – Joshua Fox
    Jan 27, 2022 at 13:38
  • @TomGewecke Indeed, the problem occurs reproducible in Whatsapp, Pages, Safari, and Slack and not in Terminal, Chrome, Atom, System Preferences search box, Pycharm , or Firefox! The difference in icon color in Sys Pref is a red herring, as it happens in either state. I edited the body to reflect this.
    – Joshua Fox
    Jan 27, 2022 at 13:56

2 Answers 2

1

I ran into the same problem without having Karabiner Elements ever on my computer. I solved it by installing my Ukelele generated keyboard layout "for all users" instead for the "current user" using the ukelele organiser. This fix is the suggested in the google-group mentioned above.

0

The solution for me was to turn Karabiner Elements off; then on!

Then, both Ukelele and Karabiner work just fine.

This also solved a secondary problem with "ghost" Input Sources reappearing repeatedly in the Input Sources list.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .