I'm making a Keynote presentation with a lot of equations. To add an equation, I can press option-CMD-E, and then I can type the LaTeX code for the equation. However, to complete editing the equation and insert it into the document, I have to move the mouse pointer to the "Insert" button and click it.

My question is whether there is a way to do this using only the keyboard, so that I can enter equations into the text without using the trackpad at all. Here's what I've tried:

  • press enter (this just puts a newline in the LaTeX code)

  • all possible combinations of enter plus one or modifier keys (shift, ctrl, option, CMD)

  • attempting to select the "Insert" button using the tab key (but it doesn't do anything)

Is there something else I could try?

The same issue affects Pages as well.

1 Answer 1


As an alternative to Insert or Update in the equation editor window in Keynote, Pages, or Numbers, you can press Command ⌘+Return ↵ on your keyboard.

  • 1
    This is really bizarre - I'm certain I'd tried this, because I noted in the question that I'd tried all possible combinations of modifier keys and return without success, and that would have been one of the first things I'd tried. But now it seems to work.
    – N. Virgo
    Commented Feb 16, 2022 at 1:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .