0

I want to keep a remote machine open in full screen and be able to switch to and from that space on my local machine. On my local machine I have f1 and f2 set to switch spaces, but all keyboard entries go to the remote machine so I have to exit full screen in order to access my local machine and switch spaces.

f1 and f2 are not set to do anything on the local machine so I just get the "this key doesn't do anything" beep.

Is there maybe a way to have some keys not forward to the remote machine and only register on the local machine? or am I missing something and there is another way to do this?

Both machines are running 12.1.

Edit: I notice now that this happens even when not in full screen. if screen sharing is the app in focus all keyboard input goes to the remote machine. I have to use mouse to unfocus screen sharing in order for keyboard to interact with local machine.

3
  • Is this new to Monterey? Just tested on older OSes & so long as the local & remote commands are not the same as each other I can invoke Space switching on either by pressing the keys appropriate to each Mac - i.stack.imgur.com/kgetj.gif [local Mac has blue desktop pic & safari, remote has purple]
    – Tetsujin
    Jan 23 at 8:37
  • i don’t know if this is new. i hope it’s not new and i just have something set wrong some how. although i don’t know what that could be
    – ndsz
    Jan 23 at 16:02
  • I can't repro your issue. I set F1 & F2 to switch Spaces on the remote & left the usual Ctrl/num & Ctrl/arrows to switch on the local. Each worked just fine, whether the remote was in fullscreen or not.
    – Tetsujin
    Jan 23 at 16:05

1 Answer 1

1

Solved-ish. I changed moving/switching spaces back to the default ctrl/arrows on the local machine and I'm able to switch normally.

Perhaps using function keys introduces some sort of issue. I tried putting back to F1 and F2 and the same thing happened as before.

I've been using F1 and F2 for quite some time so just going to take some muscle memory retraining I guess.

1
  • Confirmed. I hadn't tested it that way round. F-keys on the local don't register when you're in the remote. Ctrl/num works just fine & f-keys work inside the remote. Go figure;))
    – Tetsujin
    Jan 24 at 7:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .