7

Environment

  • Apple MBA 2020 MacBook Air9,1 / Intel / x86_64 machine
  • Host OS: macOS Big Sur 11.6.2
  • Host OS Build: 20G314
  • SW: VirtualBox 6.1.32 r149290 (also tried on VirtualBox 6.1.30 r148432)
  • Guest OS: macOS Monterey 12.1 (21C52)

Purpose

  • Upgrade VM from Big Sur 11.6.2 (fully functional with VB 6.1.32) to Monterey 12.1.
    OR
  • Installation from scratch a Monterey VM. Both have same final result: instability.

After the first boot with Monterey, the VM suddenly HANGS AND REBOOTED BY ITSELF, reporting "This system was automatically rebooted after panic". It seems it enters in a "reboot loop" because after some time, even doing nothing, a reboot still happen again and again, like in an infinite loop.

How to reproduce

  1. Open VB 6.1.32

2a. Start a VM upgraded to Monterey
OR
2b. Start a VM installed from scratch with Monterey
OR
2.c Start a VM with "Install macOS Monterey ISO" as only Storage added to VM (NO other Hardisk present)

  1. Just wait some time...

==> You'll see in 0-15 min Guest OS HANGS AND SUDDENLY REBOOTS by itself.
==> Then the console message is: "This system was automatically rebooted after panic"

Logs and info

I unfortunately continue to note the instability of Monterey as Guest with VB 6.1.32, even on Apple Hardware!

All config data, and a video are at disposal to have an idea, as well as VB Logs (see attachments).

Questions

I asked to VirtualBox forum here topic 104998 with hope of receiving helpful feedback, which has not been the case as yet.

I'm primarily interested in sharing to the community and finding other user experiences.

Does the same or similar behaviour happens to someone else?
Has anyone perhaps applied a workaround or found a fix?
Has anyone ever gotten a really stable and usable Monterey guest installation (on Mac HW) with VirtualBox?


Added later...


I just came back a few days later, just for a minor update on this topic.

I was wandering if something changed with Monterey (Host), perhaps hardware resources are managed differently in Monterey, or that more generally something has changed.

So I just repeated the tasks with the same VM, so VirtualBox 6.1.32 with Monterey (Guest) on Monterey (Host on Apple hardware)

Environment (revised)

  • Apple MBA 2020 MakBookAir9,1 / Intel / x86_64 machine
  • Host OS: macOS Monterey 12.1
  • Host OS Build: 21C52
  • SW: VirtualBox 6.1.32 r149290
  • Guest OS: macOS Monterey 12.1 (21C52)

I unfortunately note that the result is still the same: VM do a reboot loop and kernel panic.

2
  • You might consider using VMware Fusion Player. The non-commercial license is free. I have Monterey installed on a 2013 iMac host. Jan 21 at 17:17
  • Thx @DavidAnderson for your proof. I certainly will consider that, as well as moving all other VM I have (Linux, Win). VB has always been great to my needs. In the VB 6.1.30 release notes they say: "VBoxHeadless: Fixed crash when running on macOS Monterey (bug #20636)" and "macOS host: fix multiple bugs specific to macOS Monterey in installer and startup of kernel extensions" And I am sorry to see that this is not the case to me as yet, despite what they claim.
    – villoez
    Jan 22 at 9:55

2 Answers 2

11

After some research, the problem seems to be about TSC (Time Stamp Counter) emulation.

The following worked for me:

  1. Close ALL VirtualBox windows (otherwise the next setting will be overwritten)
  2. Run commandline command, where YOUR_VM_NAME is the name of your VM:
    VBoxManage setextradata "YOUR_VM_NAME" "VBoxInternal/TM/TSCMode" "RealTSCOffset"
  3. If you still see kernel panics, double-check that your .vbox file contains the applied settings and also check VM's logs for errors related to RealTSCOffset.
3
  • Absolute legend @Codeguard!
    – micwallace
    Apr 15 at 12:56
  • This worked for me on a Hackintosh with Virtualbox 6.1. It kept crashing with panic at continue after choosing to install.
    – nospam2k
    May 4 at 17:35
  • Hi, Adding the parameter RealTSCOffset to my VM seems to resolve the issue. Thanks very much, your answer save my day. cheers ;)))))
    – adia
    May 11 at 12:24
2

I found that changing number of virtual CPUs to 1 helps. But then it's slower, of course.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .