2

The "My photo stream" feature doesn't seem to be working for me as of recently.

I would like to be able to take pictures with my iPhone (iPhone SE, software version 15.1) and see and use the pictures in in the Photos application in my mac (OS Monterrey). I don't want to use any iCloud features to transfer/store my pictures.

Things I tried/verified:

  • I made sure both devices use the same Apple ID
  • I made sure that in my phone I have "my photo stream" enabled and the phone is connected to wifi (I read it won't upload pictures to the stream using cellular data)
  • I made sure that in my laptop Photos > Preferences also has "my photo stream enable".

(In my mac's System Preferences > Apple ID I see the same as in my phone, and I see "my photo stream" enabled everywhere)

Background (or other potentially related stuff)

Recently (maybe a month ago or so) I updated the OS (to Monterrey) in my mac. As I did it I was forced to change my apple ID password (apparently my Apple ID password and my iCloud password no longer could be the same). After that I had a problem when logging in in my mac and I was asked for both passwords when logging.

I researched this issue and fixed it (by dealing with keychains and forcing the computer to re-encrypt data, to remove some stored info about my Apple ID/old password user). Nothing fancy, but that can be related to the issue.

I'm mentioning this because it's the only recent change to the computer and I think I don't have any picture in Photos app from after this OS upgrade.

I took an old phone (where I have the My Stream Photos enabled too) and took a picture with it. I can see that picture in my new phone and the old phone downloaded pictures that were in the stream, taken with the new phone. It's clear from this that it's the Photos application in my mac the one that is not connecting well to the stream, but I don't understand why.

After searching on the Internet and this stack and seeing the regular advice about having the options enabled, making sure you have the right IDs in all devices, etc. I don't know what else to do to troubleshoot and fix this problem.

Why is Photos in my laptop not syncing with my stream like my other devices?

Other things I tried

  • Holding CMD + alt and starting Photos to repair
  • Deleting CloudSync.noindex
  • I could not check the iCloud option for photos, because it would force me to buy additional storage for iCloud. I was hoping to force a re-sync with this, but I can't select the iCloud option.
  • I disabled the "live" feature for my pictures, since I read that "You won’t be able to see Photo Stream Photos from iPhone or iPad on your Mac", but it didn't work for me.

1 Answer 1

2

having same issue. Had non sync happing over the years and normally it helped to upgrade the software of the iOS or sometimes MacOS upgrade. Now have latest Monterey (12.3) in Mac Mini M1 and latest iOS (15.4) in iPhone 12. Photo stream does not sync between these devices. Interestingly I have old iPhone 7 running iOS 15.3.1 that does sync fine with Photo stream to M1 and iPhone 7 photos sync to iPhone 12 as well. Just iPhone 12->Mac M1 is broken.

Photo stream broke before latest iOS update though, I upgraded to try to resolve the situation, this time upgrade did not help.

Would be great if Apple would show status of Photo stream somewhere, guessing with random settings is so annoying.

UPDATE: I got my Photo stream to work. Noticed that iPhone12 now uses HEIC codec rather than JPG after software update. Changing HEIC->JPG (Camera->formats->Most compatible) made Photo stream to work. I think reason is old iPad Air1, that is not HEIC compatible with iOS12 and as part of the same Photo stream as iPhone12/7/iPad Air/Mac M1 it blocks HEIC photos from the Photo stream.

1
  • Thx for your "answer" but this rather looks like a comment towards "I'm having a similar problem". It is not appropriate to place comments as answers just because you don't have enough reputation points.
    – Alper
    Mar 21, 2022 at 22:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .