3

I can't open my WD external drive after I reboot my mac with Monterey 12.1!

I know that so many people had a similar problem so I followed all those solutions, but they are not working for me. I need to get the documents back so I can`t erase my drive. (ps. don't want to use disk drill).

I found this https://matt.sh/apfs-object-map-free-recovery looks like something might help me but I'm not a coding guy so I'm not able to follow

I tried "mount" in disk utility and I got the (com.apple.DiskManagement.disenter error 49218.)

When I run first aid in disk utility, I got this: enter image description here

I checked the fsck , run ps aux | grep fsck but only get this

laijaco 4059 0.0 0.0 34122828 800 s000 S+ 11:12PM 0:00.00 grep fsck

2
  • 1
    Just to be sure: do you have a backup of that drive? And when you say "I followed all those solutions" can you list them in your question and indicate what didn't work for you? This prevents that someone else will spend time suggesting the same solution, and you becoming frustrated that it does not work. You can edit your question to rewrite it with the found/tried/failed attempts. Jan 17, 2022 at 14:00
  • This seem to have a serious bug in Monterey. This bug was also reported in developer.apple.com/forums/thread/695361
    – gagarine
    Feb 12, 2022 at 18:11

2 Answers 2

2

WD drives traditionally have very unreliable enclosure hardware, and you may have better luck opening it up, taking the drive out, and putting it in another enclosure. (As a last resort.)

-4

I'm afraid you will need to erase all the data contained in the hdd. Click Erase and you can either click MS-DOS(FAT), APFS or any other format in the Format section and select the scheme right below it. You can click either GUID Partition Map or Master Boot Record. Then Click Erase. (PS: it works for me when I had it wouldn't mount automatically with a name disk2s2 in it.)

1
  • 3
    The question explicitly states erasing is no option. Even if it was the only option, you should at least explain why!
    – X_841
    Jan 17, 2022 at 14:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .