5

In Safari on macOS:

  1. Open a new tab
  2. Search for something using Safari omnibar (type something into the omnibar, press enter, be presented with Google search results webpage)
  3. Click a result
  4. Press back (or cmd [)

It takes you back to new tab start page, not to search results.

How can I make it take me to search results instead? The search results page does not show up in history either.

7
  • 1
    You never opened a search results page, so there's nothing to go back to. This is not new behaviour. If you want to go back to somewhere, you need to open somewhere [eg Google search] to go back to.
    – Tetsujin
    Commented Jan 16, 2022 at 18:33
  • 1
    The very first option, inside the omnibar itself is 'Search Google' or whoever your chosen default is. Unless you actually go to a web page, there will be nothing to go back to. The list you see is generated on the fly, courtesy of Spotlight, & doesn't form part of your history.
    – Tetsujin
    Commented Jan 16, 2022 at 18:54
  • 4
    @Tetsujin that Google page doesn't go into my history nor can I go back to it after opening one of its links
    – minseong
    Commented Jan 16, 2022 at 19:54
  • 1
    I see the same results as theonlygusti. If you switch your default engine to DuckDuckGo, for example then you can see the difference: search, choose a result, find it isn't what you want and use the back button to go back to the previous results list.
    – BruceH
    Commented May 22, 2022 at 11:25
  • 1
    I have the same very issue, too. When I search something in address bar and then click a result, I cannot go back and have to search it again. I update the OS to see whether they fix this but no, and they will not, I guess. Once they fixed this but immediately they released x.x.1 version because it led security vulnerabilities.
    – Eray
    Commented Jan 28, 2023 at 6:26

4 Answers 4

3

I was experiencing this same issue. I was able to fix it by disabling all of the checkbox options in Safari search settings and clicking ok. Google searches then showed up in history. Re-enabling all these checkboxes still allowed the searches to show up in history.

  • Safari version 16.1
  • OSX Ventura 13.0.1

enter image description here

1

Even though the question is a few months old now, I recently had the same problem with Safari 15.5 and macOS 12.4. In addition, some websites did not load properly.

For me, it helped to close all open tabs and restart Safari.

1
  • I agree - I can not reproduce this on several machines I have available for testing without needing to close tabs or restart the app.
    – bmike
    Commented Oct 11, 2022 at 17:56
0

I was not able to find a way to reproduce your issue, but rather than continue in comments on another answer, I'll stake a proper answer so we can edit it into shape.

  1. Google puts one entry into my history for each "search" and then press enter (two searches produce two history entries)
  2. Duck Duck Go puts two entries (two searches produce four history entries)

You may be on to something where the "second" entry is being suppressed on your specific profile or there's a setting to suppress it. If my theory is valid - you might only get one entry for Duck Duck Go and zero for google.

To reproduce my results - clear all search history and then toggle off all the items except Include search engine suggestions (although I don't see any of these settings below changing my results)

Safari Settings on macOS Monterey

Here is what google search for two phrases shows in my history - first using Google - then using Duck Duck Go

History for Google and Duck Duck Go

I wonder if people that lack these history events have extensions or settings that may be affecting this. A quick way to isolate that would be to make a new user on your Mac and repeat the quick test above.

0

I don’t understand the comment by @Tetsujin that "you never opened a search page" when that is literally what Safari is doing when using the address bar to search Google. You search in Safari, Safari opens a Google search results page, therefore this page should be in your Safari history and Safari should go back to this page when hitting the back button after clicking on one of the results. This is a bug, plain and simple, and is not Safari's expected behavior.

My understanding is that Safari does not generate a full Google search results page "on the fly" or do any search at all other than open a search page. This to me is obviously a very annoying bug.

7
  • It is unclear how your answer resolves the problem in the OP.
    – Alper
    Commented Oct 4, 2022 at 16:13
  • I too don’t understand what you are saying Braden. Doesn’t safari on macOS have a setting to include search results in the app and spotlight itself without causing a web page to display? It’s called quick results and causes people problems when they want to block a web page and the search API gets called behind the scenes.
    – bmike
    Commented Oct 4, 2022 at 16:32
  • Also +1 for offering a post to clarify the issue - even if it’s not a direct answer (according to my opinion/understanding at the moment), it may help us all agree on terms and what’s happening.
    – bmike
    Commented Oct 4, 2022 at 16:34
  • @bmike the question's not about spotlight. The behaviour is that in Safari itself, often searching from the omnibar loads a google results page (in Safari!) that doesn't enter the browser history. I tested just now and it did this time, but often it doesn't.
    – minseong
    Commented Oct 4, 2022 at 22:01
  • 2
    @bmike No, theonlygusti is correct, I'm here because I have the same issue, and it's extremely annoying. I'm not talking about Spotlight, the Smart Search Field, or Quick Website Search. I'm talking about using the Safari address bar to navigate to Google, click on a result, and then when using the back button, the Google search result page is skipped and the new tab page is opened instead. Commented Oct 11, 2022 at 14:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .