I have an M1 Mac Mini running Sonoma 14.3. I would like to be able to put it to sleep or shut it down when not in use to conserve energy. But, I also want to be able to remotely power it up so I can access it when I need to using VNC, SMB, or SSH.

I have typically done this by sending WOL (WakeOnLan) magic packets from my home router which is pfSense. This has always worked fine—until this Mini.

I've checked the Energy Saver prefs, made sure womp=1 in pmset -g and even tried mucking around with nvram / darkwake settings. I'm sure the Ethernet MAC address is correct. Nothing has worked. WOL to an Intel NUC sitting on the same network works as expected.

What happens when I send the WOL packet is one of:

  • absolutely nothing: no lights, no activity, screen remains dark.
  • power LED comes on, Mac becomes "pingable", screen stays dark, but after 5-10 seconds, the Mac goes back to sleep. At no point during this sequence am I able to connect via VNC.

Is this a hardware bug with the M1's? Anyone know of a solution?

  • 1
    I came across this question when trying to figure out how to WOL while traveling. For me it was, I forgot the WOL doesn't work over WiFi. Wake-on-LAN is only supported over ethernet.
    – Klarence
    Commented Dec 28, 2022 at 0:20

1 Answer 1


Have you tried setting the darkwake flag to 0 in the Kernel Flag section of /Library/Preferences/SystemConfiguration/com.apple.Boot.plist


  • 2
    Yes I have tried that. I just tried it again (12.5 now). All that seemed to do was make it so my Mac can never sleep (after putting to sleep, it immediately wakes back up). I gave up again, just going to leave it on all the time. It's a shame such a simple feature is so broken on Apple hardware.
    – luckman212
    Commented Aug 7, 2022 at 16:21
  • Did you get any luck on better options @luckman212?
    – McFlurriez
    Commented Feb 29 at 10:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .