0

Objective:

Trying to read an SD Card from a Nikon DSLR.

Background:

Same SD Cards and Card Reader have worked fine before on the same computer, in previous versions of MacOS.

Hardware:

MacBook Air, Early 2014 running MacOS Big Sur 11.6.2
Anker USB 3.0 Card Reader, model AR200 (three units)
Samsung 256GiB Evo Select SDXC card
SanDisk 512GiB Extreme Pro SDXC card

Symptoms

  • Card reader flashes blue LED lights and then shows solid blue light after being connected, which indicates successful connection.
  • Nothing shows up in left pane of Finder window.
  • Nothing shows up in Disk Utility.
  • The card reader AND the correct SD card information (size) do show up in Apple -> About this Mac -> System Report under Hardware -> USB, so the card reader and card are successfully recognized by the Mac at a hardware level. The BSD name for the card reader is listed as disk2 and the media is listed as disk2s1.

Troubleshooting Steps

  • I have tried three different SD card reader units (two are brand new from the packaging) to eliminate the possibility of a bad SD card reader.
  • I have tried two different SD cards from two different manufacturers, which have both been in the camera, and neither work (both have worked previously on this same computer running previous versions of macOS).
  • In a terminal window, mount does not show any listings for disk2 or disk2s1.
  • In a terminal window, mount /dev/disk2s1 returns the following: mount: /dev/disk2s1: unknown special file or file system.
  • In a terminal window, mount -t exfat /dev/disk2s1/ /Volumes/Test1 returns the following: Executing: /usr/bin/kmutil load -p /System/Library/Extensions/exfat.kext. It then hangs on this step and nothing happens.
  • Following some other suggestions from a google search, I tried checking ps aux | grep fsck but had no results. I did a pkill -f fsck anyway just to be sure, and accomplished nothing.
  • Everything works fine on a Windows test machine.

Possibly Related Threads

MacBook: SD Card Reader Not Visible
MacBook Pro Late-2013 SD card reader not loading cards after 10.10.2 update
macOS: Can't mount exFAT External Drive
https://www.reddit.com/r/editors/comments/jch0i7/exfat_drive_not_reading_on_mac_wont_mount/

5
  • Just to double-check, is Disk Utility set to Volume view, or Device view? [Switch with Cmd/1 Cmd/2]
    – Tetsujin
    Commented Jan 10, 2022 at 12:10
  • 1
    Device view. It doesn't show up under either view. Only my internal drive shows.
    – Daniel
    Commented Jan 10, 2022 at 12:52
  • Do other SD cards appear in macOS using this card reader?
    – IconDaemon
    Commented Jan 10, 2022 at 13:12
  • I only use SD cards for my cameras. I tried another card that is in my Olympus camera and it has the same behavior. But since it is also an SDXC card, I'm guessing it's the same problem with exFAT? (That's a third card, to be clear.)
    – Daniel
    Commented Jan 10, 2022 at 17:32
  • It's hard to tell from this whether the Mac doesn't like the Anker, or doesn't like SDXC cards. Next step would be to test out one or other of those to eliminate further.
    – Tetsujin
    Commented Jan 11, 2022 at 9:13

0

You must log in to answer this question.

Browse other questions tagged .