3

Upon booting up by machine (2021 MacBook Pro 14 on 12.1) after fully running out of battery for the first time (I've owned the machine for a couple months) I noticed the date and time were completely wrong by a number of months. The offset is consistent and displays today's date as 25th September 2021, it is currently the 8th of January 2022.

date and time preference pane

I've tried resetting the SMC, restarted the machine a few times, have checked all date and time settings as normal and appropriate - unchanged from when I first set it up.

alex@Alexs-MacBook-Pro ~ % ntpdate -q pool.ntp.org
server 188.125.64.7, stratum 2, offset +9088877.936268, delay 0.07085
server 162.159.200.1, stratum 3, offset +9088877.930845, delay 0.05722
server 162.159.200.123, stratum 3, offset +9088877.932137, delay 0.05659
server 85.91.1.180, stratum 2, offset +9088877.938617, delay 0.05498
25 Sep 06:35:35 ntpdate[1630]: step time server 85.91.1.180 offset +9088877.938617 sec

Running the following command resyncs the date and time perfectly, but after about a day when left in automatic mode or by unchecking and rechecking the box it resets back to the massive offset.

sudo sntp -sS time.apple.com

I noticed a user with a similar problem in the forum but was unable to use any solutions provided:

Date is wrong by months when set to automatically

8
  • Try switching it to manual, set it somewhere close to correct, reboot & try auto again.
    – Tetsujin
    Jan 8 at 10:37
  • 1
    @Tetsujin Thanks for the suggestion, but unfortunately the issue persists.
    – A. McHugh
    Jan 8 at 10:45
  • Can you show us a screenshot of the Date & Time Preference pane, with the server set automatically?
    – benwiggy
    Jan 8 at 11:11
  • 1
    @benwiggy added one to the post.
    – A. McHugh
    Jan 8 at 11:50
  • I have seen de-selecting automatic time zone as a solution.
    – benwiggy
    Jan 8 at 13:13

1 Answer 1

3

I had the same issue and solved it as follows:

  • the process responsible for the system clock is "timed"
  • the man page says it stores its configs in /etc/ntp.conf and /var/db/timed/com.apple.timed.plist

I manually deleted both files and restarted my mac. You need root to delete the files. Now sntp to time.apple.com shows an offset of 2secs, but that seems to be a known bug.

2
  • Thanks! This worked.
    – A. McHugh
    Mar 1 at 16:56
  • Thanks, so much! This was the only answer I found that worked.
    – SylarBenes
    Jul 13 at 18:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .