16

Bluetooth audio is choppy / stuttering on Retina 5K, 27-inch, 2020, macOS 12.1 using Bose QC45s

Audio constantly stutters. I thought it was Spotify, so I switched to Apple Music, and the same thing continues.

I have seen this solution in a few posts:

Go to: Apple Menu > System Preferences > General and uncheck the option "Allow Handoff between this Mac and your iCloud devices".

It does not work. Any suggestions?

4
  • I'm also having this issue. It is so bad that I am not able to use any bluetooth headphones with it. MBP 2021, 14-inch, macOS 12.1 Jan 14, 2022 at 0:56
  • Mine works when I turn off one of the bluetooth devices, in this case my Microsoft Mouse. It still works even after turning it back on. Jan 14, 2022 at 1:01
  • Also applies to my MBP 16 2021 on Ventura 13.2.1.
    – Erik
    Mar 13, 2023 at 9:00
  • I've been using a bluetooth mouse, keyboard and trackpad for a while and just added a new Bluetooth headset and am experiencing this. Sure enough, disabling one of the Bluetooth devices seems to solve this - is there any more information now about available solutions? Has Apple resolved this? I should mention I'm on an Intel mac (2020), so the M1 answer below isn't relevant.
    – Joe Healey
    Jun 20, 2023 at 14:24

8 Answers 8

8

For users with the M1 chip (also works with intel Macs):

If you're encountering stuttering issues, it's worth checking the number of connected Bluetooth devices. If you have three or more devices connected, this could be the root cause. One possible solution is to disable one of the Bluetooth devices, which helped resolve the stuttering problem in my case. It appears that there is a known issue with the M1 chip, where three or more Bluetooth connections can lead to stuttering. The maximum number of connections without experiencing any stuttering appears to be two.

System:

Chip: Apple M1 
Memory: 16 GB
macOS: Ventura 13.3.1 (a)
6
  • 1
    This solved my issue. I also had a trackpad and a magic keyboard connected via Bluetooth. Connected one of them via a USB and the problem was gone.
    – jpbalarini
    Jun 19, 2023 at 16:13
  • I managed to have 3 devices connected without stuttering by reducing strength of the router’s wifi 2.4 GHz band. Jul 11, 2023 at 15:25
  • I'm guessing it's not so much the number of connected devices but the number and the behavior of each. For myself, I had the Apple Magic Keyboard (4th device) which was turned on but not in use. Once I turned off that keyboard, I was just fine with 3 Bluetooth devices, including my headphones
    – huyz
    Aug 31, 2023 at 10:21
  • This solved my issue as well.
    – blispr
    Nov 17, 2023 at 13:52
  • So this is related to M1? Also M1 Pro? Does this mean I need to upgrade my MacBook because of this? 😂
    – mti
    Dec 31, 2023 at 13:08
3

On macOS Ventura 13.0 the solution seems to disable AirPlay.

Go to Apple menu > General > AirDrop & Handoff > Disable AirPlay reciever

I don't know if this problem is caused by my JBL Live Pro 2 TWS, or macOS itself though.

2
  • 3
    Didn't change a thing for me unfortunately Dec 15, 2022 at 12:54
  • This did help me, but the problem seems to have come back. Seems to go away after a restart, and is generally fine for a day, but appears again the next day if I don't shutdown or restart. Very odd. I've also attempted turning off Airplay Receiver, but so far without a restart, that hasn't helped either at all, or much. My symptom is a brief (Probably <50ms) pause in audio every 3s or so. Bose QC35II, which are fine with other audio sources (Windows laptop, Samsung phone).
    – TheHud
    Jan 20, 2023 at 13:11
1

I had the same issue. Tried everything above and nothing helped. What did help a lot was removing unused devices from the "My devices" list.

0

I solved this by going to bluetooth preferences, click on your speaker as the output and also click on the input and select your bluetooth speaker in question. By default its set to computer input and output

1
  • 1
    It’s not clear how changing the audio input/output from the default will address audio choppiness. Can you elaborate?
    – Allan
    Jun 3, 2023 at 15:34
0

Something that helped for me is removing the Bose from the list of connected on all other devices. I.e., I removed the Bose from my phone's Bluetooth setting (not just removing the connection, but completely deleting the device).

However, this did not fix the problem entirely. The stuttering became significantly less frequent (from multiple times per hour to maybe 1-2x a day). Also, sometimes the headphones just stop playing any music for unknown reasons and the only way to fix this is turning them off and on again.

0

The problem you are experiencing may be related to an application requesting access to the microphone built into your headphones. Applications that use microphone access may briefly interrupt or change the sound of your music.

  1. open System Preferences on your Mac.

  2. click on the "Security & Privacy" option

  3. select 'Microphone

  4. you will see a list of applications that have access to your microphone. Check these and see if any of the applications that have access to your microphone might be open while you are playing your music.

  5. if you have found this application, try disabling microphone access or closing the application when listening to music via Bluetooth.

  6. now test to see if the stuttering issues are resolved.

  7. newer Mac versions show which applications are currently using the microphone in the menu bar at the top.

  8. what also helps is to reconnect the headset. This causes a sort of forced disconnect in the application.

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Nov 8, 2023 at 8:25
0

In my experience it has been related to multipoint connection on the headset. Both sony xm series and bose qc series.

When turning on the headset, it auto-connects to both the mac and your phone. If i disable bluetooth on my phone it fixes my issues

0

I was facing this issue with my JBL Flip 5 Bluetooth speaker and my Mac Mini M2 setup. I have a Logitech Flip mouse and a Logitech keyboard, both Bluetooth, connected to my Mac.

I could barely play anything on my speaker before it started stuttering and disconnected. Disconnecting either my mouse or keyboard definitely helped but that wasn't a solution for me. Instead I switched my WiFi to a 5GHz band from the usual 2.4GHz and it seemed to have solved the issue. Now I have three devices connected over Bluetooth, and all of them are working flawlessly without any issues. Kindly see if it works for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .