5

I just added my Apple ID to a new MacBook Pro and tried to turn on iTunes Match. This is the error I get:

iTunes Match Error

The only info I can find indicates this is a connection error, but I can connect to other areas of the iTunes Store. Any ideas how I can resolve this?

4 Answers 4

2
+50

According to this discussion or this one it seems (-54) is a file-lock problem. The proposed solutions are:

  • an AppleScript to remove locks

    Open the Script Editor in the /Applications/Utilities folder and run the following:
    tell application "Finder" set locked of every item of entire contents of folder "Music:iTunes" of home to false end tell

  • use Terminal to ensure ownership, group, and permissions are correct
    • use sudo chown your-username your-filename if you don't own the file/folder
    • use sudo chgrp staff your-filename if it isn't set to the same group as other iTunes items
    • use chmod 666 your-filename and/or chmod 777 your-folder-name to make sure everyone (and thing) can edit
  • disabling FileVault if used

In particular, check the permissions on the iTunes/Download folder which is where iTunes will first attempt to download "matched" songs.

2
  • Seems like a valid answer so I'm accepting, but unfortunately due to corp policy I'm not able to turn off FileVault. The AppleScript solution did not work for me either.
    – AJ.
    Mar 21, 2012 at 16:31
  • 1
    chmod 666/777 is a security issue, especially in a shared/corporate environment. chmod'ing to 600/700 should be enough to avoid any permission issues for the current user.
    – nohillside
    Jan 31, 2013 at 6:34
0

Check out this video and see if it solves your problem. The intro is annoying, but I hope it helps.

1
  • No, sorry...note in my question I state that I'm using a MacBook Pro.
    – AJ.
    Mar 16, 2012 at 16:24
0

It's a permissions denied error.

  • Are you sure your Apple ID hasn't been linked to more then 5 devices?
  • Have you tried to log out- and in again?
  • Has iTunes Match worked before?
3
  • 2
    How did you arrive from -54 to permissions denied? Might be worthwhile to post a link to whatever source helped you interpret that. Mar 16, 2012 at 15:34
  • Answers to your bullets: yes I'm sure it's not, yes I've tried logging out and back in, yes for my account, but not on this computer.
    – AJ.
    Mar 16, 2012 at 16:25
  • I know it's an easy shot, but how about rebooting your Mac or reinstalling iTunes?
    – Michiel
    Mar 18, 2012 at 13:33
0

I just ran the standard disk utility and restored permissions on the tome which contained my iTunes library. That took about a minute and fixed the problem for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .