1

Using Cisco AnyConnect to connect to my company VPN from my personal computer. No problem installing and running the app but if I disconnect AnyConnect (icon in the menu bar > Disconnect), then I can't access the internet anymore. Note that I cannot quit the application, I can only disconnect it. If I uninstall AnyConnect completely then I can access the internet again. I compared my wifi network settings (Wi-fi, TCP/IP, DNS, etc. tabs) before and after the installation and they are the same.

I assume AnyConnect must have change the network settings somewhere else though. Any idea where I should start looking?

AnyConnect version: 4.10.03104

OS version: 11.5.2

2
  • I am having this problem as well on MacOS 12.1 One thing I notice is that in System Preferences, Network the adaptor still shows as connected after disconnecting in AnyConnect, and quitting the app. Jan 7, 2022 at 17:11
  • I've run into similar issues, but the internet connection just dies in the middle of being used. It seems to be the network filters it installs – if they're deleted, the network is restored.
    – Phoebe
    Jul 7, 2022 at 19:14

1 Answer 1

1

I think this has to do with the AnyConnect profile file in /opt/cisco/anyconnect/profile/. I played a bit with the attributes there (AutomaticVPNPolicy, AlwaysOn) and was able to quit AnyConnect and access the internet.

(Still looking for a better way to switch between VPN and no-VPN modes)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .