0

Stellaris runs but gives this error:

Unexpected error occurred during database initialization. Please verify that you can access the file /users/gw/Documents/Paradox Interactive/Stellaris/launcher-v2.sqlite

Here's what I've done:

  1. I've set the permissions of this file and all its enclosing files (up to .../Documents/Paradox Interactive) to read/write for me/staff/everyone.
  2. I've done the same thing for the relevant files in /Users/gw/Library/Application Support/paradox-launcher/v2 and ...Application Support/Paradox Interactive/Stellaris.

I've just noticed that many files and directories in (1) and (2) have date-modified set to today. However, files launcher-v2.sqlite and game_data.jsn were not modified today, but rather have a date in 2021 around the time I bought the software through Steam. These two files are read/write for me/staff/everyone.

I've also tried turning off my Norton 360, which doesn't seem to help. So I'm mystified by what's causing these two files to not be read by the Stellaris game. Thanks for all answers, clues, or feedback!

1
  • Perhaps the files have been corrupted somehow. Do you have a Time Machine backup which you can use to restore older versions of these files?
    – IconDaemon
    Jan 2 at 0:11

1 Answer 1

1

Go into System Preferences > Security & Privacy. With the Privacy menu item selected, choose Files & Folders. In the right-hand panel, you'll see a list of applications. Under Paradox Launcher, make sure the checkbox next to Documents Folder is selected.

1
  • This solved the problem and alerted me to a new aspect of MacOS security. Many thanks! Jan 17 at 20:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .