1

It looks like the indexing of network drives in Monterey is not working properly.

All Search Results categories are checked in Spotlight settings and nothing is in the Privacy exclusion list. My system drive is indexed correctly and spotlight is working fine there. However, I have two network drives mounted on /volumes.

The indexing is enabled.

Prompt> mdutil -as
/:
    Indexing enabled. 
/System/Volumes/Data:
    Indexing enabled. 
/Volumes/ludo:
    Indexing enabled. 
/Volumes/video:
    Indexing enabled. 

Spotlight seems to do the indexing job as we can see the indexing progress bar when trying to do a search.

Spotlight indexing in progress

But no results (after indexing complete of course), and no .Spotlight-V100 folders on the external drives as well. I don't know if Spotlight still stores the indexing files there in Monterey (The folder isn't on the system drive either, where search is working fine).

So, is Monterey having an issue there? The exact same setup was working fine on another MBP and another OS version. Did anybody succeed in indexing external drives on Monterey?

I tried turning indexing off and on again with sudo mdutil -i off /Volumes/Drive_to_index and sudo mdutil -i on /Volumes/Drive_to_index, rebuilding the index with a sudo mdutil -E /Volumes/Drive_to_index but no changes.


Edit:

Following Rory's answer, there is no hidden .metadata_never_index_unless_rootfs file on any of my external hard drives.

2 Answers 2

0

So after weeks of not being able to access my sample library and music files on my external drive post-Monterey update, I was feeling very discouraged, especially after searching this forum and the web to no avail for a solution to the indexing and spotlight issue with the current OS. Today I am pleased to say I have found a solution that works and I am currently watching the light on my Glyph studio raid flicker as Spotlight scours the files on said HD.

First, go into Finder and press Shift+Cmd+. (yes that is a period) This will allow you to see the hidden files on your external drive

Search for a file named like the one below

.metadata_never_index_unless_rootfs

delete the file in Finder, then eject the drive. Then re-mount the drive and run this in Terminal:

sudo mdutil -a -i on

Once that is done your external drive should begin indexing and you should be able to use spotlight to locate files on your ext HD.

I hope this helps, I have been trying to fix this for over a month now.

1
  • Hi, Thanks for your answer. Unfortunately, no such file on my external hard drives. I updated my question with this information.
    – LudoMC
    Jan 14 at 8:24
0

I had your same problem and nothing helped.

But as mentioned in this answer, you can fix by disabling & re-enabling the indexing via shell, with:

sudo mdutil -a -i off
sudo mdutil -a -i on

CPU use should go up, showing the mds and mds_stores processes being busy indexing the drive; there will be also an Indexing.. progress bar inside Spotlight.


Disclaimer: I tried the exact same commands last week (confirmed by history | grep mdutil), and it didn't really fix anything.
Today instead it works. 🤷‍♂️

2
  • Hi and thanks for your answer. As stated in my initial post, I already tried deactivating and reactivating the indexing with mdutil -i off and on again, the indexing bar inside Spotlight being visible as you said (see my included screenshot). First thing that I tried but no changes on my side. Do you have a hidden .Spotlight-V100 folder at the root of your (now indexed) external drive or is it no more present in Monterey?
    – LudoMC
    Feb 18 at 16:42
  • Sorry, my fault. I was talking of normal non-network drives and brought my solution without checking again the question. And atm I have no network drive to try. – I also don't have the /.Spotlight-V100 folder, but I can find one at /System/Volumes/Data/.Spotlight-V100; although its modification is dated 2019, when I bought the laptop, and I upgraded to Monterey only in 2021, so I am not sure if that's the actual folder used for indexing (owner is admin). You can try to check into /System/Volumes/Data/Network tho. Mar 23 at 14:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .