I have a strange little problem on my hands here.

All this while, I've been using iPhone tethering via USB, and all was well.

However, today afternoon, my iPhone USB interface in the Network pane keeps stating that my iPhone USB interface is 'Not Connected'.

Enabling and disabling the Personal Hotspot option on my iPhone does not seem to get it back.

Does anyone here have any idea how I would solve this?

Machine: MacBook Pro, OS X Lion v10.7.3.

iPhone: iPhone4, iOS 5.0.1

  • Have you tried restarting you computer ?
    – iolsmit
    Mar 12, 2012 at 18:04
  • Does the cable still work for other things?
    – GEdgar
    Mar 12, 2012 at 21:49
  • Yes, I've been restarting it each time I make a change to the Network settings, but to no avail. @GEdgar: Yes, iTunes still detects my iPhone, and I am able to sync stuff to my iPhone normally.
    – Earthling
    Mar 13, 2012 at 2:50
  • 2
    Hi All, after much scouring on Google, I have finally found a solution to my above-mentioned problem. Turns out that the version of the iPhone Configuration Utility contained a nerfed version of a certain kext file. Just in case other people have the same problem, please refer to the following link: discussions.apple.com/thread/3787866
    – Earthling
    May 24, 2012 at 3:39
  • @Earthling When you find and answer to your own question, answer it rather than commenting it, so the question is marked as answered. Answers are answers (or solutions) comments are comments about the question itself.
    – zmilojko
    Oct 4, 2015 at 7:36

9 Answers 9


Over here the iPhone USB interface in the Network pane also keeps displaying 'not connected' when the USB cable is connected to the iPhone.

  • Mac OS X: 10.6.8
  • iPhone: 4
  • iOS: 5.1
  • iTunes: 10.6.3
  • iPhone Configuration Utility: 3.5

The cause is a faulty /System/Library/Extensions/AppleUSBEthernetHost.kext, though the version 2.3.0 is correct, its size of 78 KB, 60.892 bytes is not.

A known to be working AppleUSBEthernetHost.kext for iPhone USB tethering is version 2.3.0, but 225 KB, 189.646 bytes.

The fix is:

  1. In Terminal: $ sudo rm -r /System/Library/Extensions/AppleUSBEthernetHost.kext # to remove
  2. Restart (not sure whether this is necessary)
  3. Reinstall iTunes (in our case 10.6.3), this also installs the good AppleUSBEthernetHost.kext: download iTunes from https://www.apple.com/itunes/ and run the installer, this will install the correct AppleUSBEthernetHost.kext.

When tethering still doesn't work:

  1. Apple menu > System Preferences > Networking > remove iPhone
  2. add the iPhone again
  3. hit the [Apply] button

PS According to our backup software somewhere around May 7th, 2010 a newer version of AppleUSBEthernetHost.kext was installed.

  • I can confirm that this can still cause problems on Yosemite in 2015. Solution is the same.
    – zmilojko
    Oct 4, 2015 at 7:38
  • Just fixed it for me on OS X 10.10.5 with an iPhone 6 running iOS 9.0.2. I had the iPhone connected while reinstalling iTunes, and as the install process was just about to complete, the computer recognized the phone and the iPhone USB Connection in System Preferences > Network changed to "Connected."
    – simmer
    Oct 10, 2015 at 17:59

I've just experienced this problem, and resetting the network settings on the iPhone seemed to fix it.
1. Unplug your phone from your computer
2. On your iPhone: Settings > General > Reset > Reset Network Settings
3. Wait for the iPhone to restart, then plug the phone back into your computer and wait 10-20 seconds

  • Didn't work for me. I have tried rebooting the computer multiple times, tried rebooting the phone. None of that worked. I also tried this solution, just now. It changed nothing. Still no USB tethering.
    – Cheeso
    Oct 18, 2013 at 0:33

I had this issue, and I have a Mac Mini running Lion that I just installed a week or so ago. I have a Verizon iPhone 4 (no S), running iOS 5.1.

Here is the reality that I just discovered...

Make sure the iPhone "Cellular Data" is active (it will be unless you phyiscally turn it off, like, for testing). Turn on the Personal Hotspot on the iPhone.

Connect your iPhone to your Mac via a USB cable.

Go into the Sharing on the Mac, and go to Internet Sharing. The iPhone USB will appear and from the Internet Sharing standpoint, it will actually allow you to select "from Ehternet to iPhone USB" but, it doesn't actually work.

In reality you can only share this the other way, ie, share internet from iPhone USB TO the Mac. Perhaps Apple is readying the ability share the other way via USB, but it isn't there, yet

However, as long as you have an ethernet connection and a Wi-Fi on the Mac, you can share FROM the Mac to the iPhone via Wi-Fi, essentially setting up a Computer-to-Computer connection between the Mac and the iPhone (or, in more modern terms, the Mac becomes a hotspot).

I have read that perhaps with earlier versions of OSX the USB went the otherway, but I have never gotten it to work, and I highly doubt Apple would have taken that away, as opposed to adding it.

Hope this helps.

  • 1
    This doesn't really address the question, which is how to get USB tethering to work again.
    – Cheeso
    Oct 18, 2013 at 5:20

In addition to ProBackup's instructions, removing and purging iPhone Configuration Utility seems to help (from here) :

  1. Delete iPhone configuration utility.

  2. Purge files related to iPhone Configuration Utility :

    sudo rm -rf /private/var/db/receipts/com.apple.pkg.iPhoneConfigurationUtility.*
    rm -rf ~/Library/Preferences/com.apple.iPhoneConfigurationUtility.plist*
  3. Delete the whole folder:

    sudo rm /System/Library/Extensions/AppleUSBEthernetHost.kext
  4. Reinstall iTunes (just over the previous one)

  5. Restart

In my case, I did not have the iphone config util so instructions #3 - #5 worked fine !


After several hours of effort, I thought I'd contribute my experience. Maybe it will save some other people some time.

Macbook Pro
Mac OSX 10.7.5
Itunes 11.1.1
iphone 5, ios 7.0.2

At some point, I don't know when exactly, maybe after installing itunes 11.0, USB tethering stopped working. In an effort to rectify this problem, I went into Network Settings, and deleted the iphone USB network, thinking I would be able to re-add it. No go. It was really just gone, and when I clicked +, I could not add it again.

The main resource I used for this is here: https://discussionsjapan.apple.com/thread/10102167?start=15&tstart=0

I used Google Translate to translate the page. Basically, it's a more thorough and persuasive discussion of the problems related to AppleUSBEthernetHost.kext that are discussed elsewhere.

I looked in /var/log/system.log and saw the tell-tale signs that the USB tethering was not going to work:

Com.apple.kextd [10] Failed to load / System / Library / Extensions / AppleUSBEthernetHost.kext - (libkern / kext) link error. Com.apple.kextd [10] Load com.apple.driver.AppleUSBEthernetHost failed; removing personalities. kernel kxld [com.apple.driver.AppleUSBEthernetHost]:. The super class vtable 'vtable for IOEthernetController' for vtable 'vtable for AppleUSBEthernetHost' is out of date. Make sure your kext has been built against the correct headers. Kernel Can't load kext com.apple.driver.AppleUSBEthernetHost - link failed. Kernel Failed to load executable for kext com.apple.driver.AppleUSBEthernetHost.

This was after installing iTunes latest, which was 11.1.1. I examined the version.plist for the AppleUSBEthernetHost.kext and saw 7.0, which seemd right. Maybe it's not built properly for my machine. I don't know.

So I downloaded this: http://carlogent.com/KextUtilityFix.zip It includes the old v2.3.0 AppleUSBEthernetHost.kext , as well as the KextUtil from cVad. I removed the old AppleUSBEthernetHost.kext from /System/Library/Extensions and dropped this one in, using KextUtil. This did not fix the problem. Yet!

I again looked in the system.log file and saw messages about a kernel cache being out of sync with the actual kexts. So I thought - how do I rebuild the kernel cache?

I then ran sudo kextcache (dang, I forget the exact command) to rebuild the cache from the command line.

Then reboot.

At this point I plugged in the iphone via USB, and opened the Network settings. I could + to add the Iphone USB which was missing. But still this connection was not active. It read "Not Connected". Examining the kernel.log file, I could see the kernel was detecting the iphone being plugged in, and unplugged, repeatedly. Then, back in the Network Settings dialog box, I clicked the little "lock" icon that prevents further changes. Voila. the iphone USB became "Connected", and everything began working as expected.


  • I'd been trying to get my USB working for weeks now and this is the only solution that worked. Btw, rebuilting the kernel cache can be done by executing sudo touch /System/Library/Extensions and then rebooting the machine. Also, I had exactly the same symptoms as Cheeso, albeit with an iPhone4s.
    – dandan78
    Oct 31, 2013 at 7:56
  • Macbook Pro Mac OSX 10.7.5 Itunes 11.1.2 iphone 4S, iOS 7.0.2 I just did what Cheeso said,in fact simpler : downloaded and ran the carlogent.com/KextUtilityFix.zip inserted the file kext into the window as instructed. Tried to rebuild the Kernel cache but did not succeed because I could not enter my password into the Terminal ( Not sure that was the right spot to run instructions on MacOS). So I gave up, rebooted, then on Network Preferences my iPhone finally appeared but would not come green , it did eventually after ticking the padlock closed. So thank you very much for your great hel
    – user62066
    Nov 9, 2013 at 23:49

TL;DR Reinstalling iTunes solved my variant of the issue because it recreated /System/Library/Extensions/AppleUSBEthernetHost.kext, which either iTunes or OSX Network prefpane deleted. Just experienced this on OSX Yosemite (10.10.4) after upgrading iTunes and resetting the network devices (esp. deleting an iPhone USB network device which seemed to have been misbehaving). Again, reinstalling iTunes (12.2 in this case) solved this.

  • Xcode was the culprit for me - reinstalling replaced the AppleUSBEthernetHost.kext, and my USB connection started working fine.
    – leanne
    Sep 25, 2015 at 3:18

I ran into this after installing Little Snitch. Uninstalling it fixed the problem.


Did you try good ol' method from PC days - turning off and on again?

It worked for me with different personal hotspot problem.

  • Hi Tomek, as mentioned above, restarting seems to do absolutely no good.
    – Earthling
    Mar 13, 2012 at 2:52

Well now it will work with the new upgrade.. Go to App Store and upgrade you Mac with the new version "OS X Mavericks". It might take a while but it will make it work. It works!!! 100% proved. Greetings!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .