1

Whatever I try, entering correct iCloud username and password still does literally nothing in App Store. It just does not work!

iCloud account logout, shutdown, and start again and login does not help.

Even quite promising advice login/logout and login again to Music app, which is now responsible for proprietary content, didn't work, also I would give it a chance at first place.

All forums full of advice do not help, and such advice like delete your system and iCloud keychain are insane, as this leads directly to losing your data and of cause does not help to resolve App store login issue. Do not follow such if you encounter.

Commands in Terminal regarding reset of Apple store do no work.

Literally lost hours, after moving data to new hardware and stuck.

Everything works except App store!

I cannot login, cannot install new apps, cannot update existing apps...

Update: At the moment of question it was MacOS Mojave, but since network stack configuration is quite system thing, it is located in still the same location on macOS Catalina, and I just checked Monterey, it's still the same.

2 Answers 2

0

Lost one day to get to resolution. Login to App Store on Mac is solved now.

I seems, that is OS is moved to new hardware, the network interface configurations mess up from previous NICs and WiFi interfaces.

Well, I had to reset macOS network system settings so it can build the interfaces fresh. Open terminal and run the following:

sudo rm /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
sudo rm /Library/Preferences/SystemConfiguration/preferences.plist

Once done, reboot and login, wait a little to settle down the OS startup tasks, I was asked to confirm my iCloud account again. So Open App Store, login, and it works! I see my purchases and apps, I can upgrade and install new apps again!

PS. look around that folder /Library/Preferences/SystemConfiguration/, I have tons of copies of such network interface config files. (really old install, but it takes days to setup the same)

Just look for more

sudo ls -l /Library/Preferences/SystemConfiguration/
1
  • 2
    This (and the question, too) would be more useful if you specified the versions of macOS that were involved. May 29, 2022 at 15:35
0

I had this problem on Mojave (a reverse issue from an error in iCloud Preferences). Getting a "Cannot login to App Store (com.apple.commerce.server error 503)", or no response.

I signed in to the App Store from another account, to see which files were changed using FSMonitor (a very handy app to visualize the files involved with specific operations).

Unlike MacPaw's or Apple's own suggestions to log into other apps. This problem is a corrupt cache of the App Store app (only), and unrelated to other apps requiring an Apple ID login.

To fully clear the App Store sign-in cache & preferences, the folders & files to be removed are:

~/Library/Caches/com.apple.appstore/
~/Library/Caches/com.apple.CommerceKit.TransactionServices/
~/Library/Cookies/com.apple.appstore.binarycookies
~/Library/Preferences/com.apple.AppStore.plist
~/Library/Preferences/com.apple.commerce.plist

PS: I deleted them from the root account. (not required though, just close the App Store first)

visual of files deleted in the Mac OS trash

I logged back in to the main user, re-signing-in to the App Store successfully after that!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .