2

I'm trying to do what should be a fairly simple task: have Finder and Quick Look view .md and .markdown files as if they had the extension .txt. As per previous answers on this topic, I had installed the QLMarkdown plugin in my /Library/Quicklook to make this happen, and it was working fine for a while.

Recently I had a hardware disaster that required Apple to wipe and replace my hard drive, with the new one running Monterey. In this new system, the QLMarkdown plugin is not working. I tried copying the latest version (1.3.6) into the /Library/Quicklook and, as per the readme, I ran qlmanage -r in the terminal to refresh. Then I got an error from Apple saying it would not run because Apple could not check it for malicious software. No option to override.

The previous answers suggest I could install Homebrew and run "brew cask install qlmarkdown", but following the Homebrew install instructions wound up causing a system freeze and reboot - and QuickLook wasn't working any better after that.

How do I get QuickLook to recognize Markdown on Monterey under these circumstances?

1 Answer 1

3

Short answer

If you've (recently) done brew install --cask qlmarkdown, you probably just need to run QLMarkdown.app to activate the plugin.

If you can't/don't use homebrew, make sure you're using this version of qlmarkdown: sbarex/QLMarkdown — and follow the instructions there.

Long answer

For a long time, the QLMarkdown plugin was this one: toland/qlmarkdown, and that's what you'd get even if you installed it from homebrew. That version basically consists of a "qlmarkdown.qlgenerator" file which needs to be copied to some particular folder — as described in the question above.

Unfortunately, that project has been abandoned.

The good news is that it's been replaced with sbarex/QLMarkdown, which I can report works great under Monterey. In fact, if you do a brew cask --install qlmarkdown today, this is the version you get — which is very helpful!

But this new project works slightly differently: instead of installing a "qlmarkdown.qlgenerator" file somewhere, the plugin is delivered as an app (QLMarkdown.app) which you need to run before the extension is available. (You may also need to enable the extension in System Preferences > Extensions > Quick Look.)

If you've run brew install --cask qlmarkdown relatively recently, you've probably got this updated version, so the solution is probably just "run the app". (BTW you might also want to pass --no-quarantine to brew install so it skips that tediousness, assuming you trust the cask of course 😄)

(BTW I've seen some chatter suggesting that "*.qlgenerator" is deprecated as a way of installing QuickLook plugins since Catalina, but I can't find confirmation of it, and AFAICS some plugins in that style still work, e.g. qlvideo. 🤷‍♂️ )

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .