I have a Cannon MP560 that kept having communications errors. One of the suggestions I read was to remove the printer from the print & scan menu and re-add it. Once I did that the scanner disappeared as well and I cannot get OSX 10.7 to recognize this device as a scanner again.

  • Does anybody know how I can get OSX to recognize this device as a scanner again?

Here are some screenshots of my print & scan screen and my add printer dialogue. Bonjour does not show me any information about this device either.

enter image description here

enter image description here

5 Answers 5


Have you tried deleting the .plists associated with the printer? These are all in my ~/Library/Preferences list. I would move them to the desktop (just in case you want to move them back), restart your Mac, and try adding the printer again.

  • So, I guess deleting the Preferences worked out? :)
    – Michiel
    Mar 18, 2012 at 22:00

Canon has updated most of their software (Easy-PhotoPrintEX, MP Navigator) and their drivers (printer, scanner) around the time when Lion came out. Make sure that you have the latest drivers installed.

You can download all the Canon software for your MP560 Scanner here.

Also, be sure to connect your printer via cable in order to use it as a scanner:

enter image description here

  • 1
    Thanks, I've updated the software both through the cannon site, and shortly after using my apple update. Still no luck. I can print fine but the device still doesn't show up. Mar 16, 2012 at 13:39
  • @bittersweetryan Can you scan using the MP Navigator EX software? That's what I'm using for scanning with my MP530.
    – gentmatt
    Mar 16, 2012 at 14:07
  • @bittersweetryan Do you have connected the MP530 wirelessly?
    – gentmatt
    Mar 16, 2012 at 14:16
  • Yes, and i was able to scan wireless previously without using the MP Navigator. Mar 18, 2012 at 21:35
  • @bittersweetryan Which .plist files did you remove? Unfortunately, I can't get this to work with my printer :(
    – gentmatt
    Mar 19, 2012 at 7:00

How to scan wirelessly: if anyone is still interested in using their MP560 scanner wirelessly on OSX Mavericks, I successfully used Image Capture from Applications.

Note the printer must be installed and recognized as a wireless printer - the MP560 will show up twice. Initially I had to install the MP560 via USB cable.

  • Beware, the question is related to MacOS X 10.7.
    – dan
    Sep 22, 2014 at 13:20

After updating my Mac to Yosemite, my Canon MX350 wouldn't scan. Type in www.usa.canon.com/cusa/support/consumer You'll be on Get Product Support. Type in your model (eg. PIXMA MX350) click Go. You should see Operating System Yosemite (detected). Look for the series Scanner Driver Ver. and click Select. Then you'll see Download and click that and go through the download "motions. Restart the computer and your scanner should be working great. I just clicked on the icon MP Navigator EX in my dock and viola, it was all there. This is how I fixed mine after spending hours watching videos and reading so many suggestions. I just did this and actually figured it out myself. Hope this can help others!! Cheers!


New Scanning Instructions:

Canon MP560 to Mac Computer with OS X Yosemite

(Use USB cable to port)

Go to system Preference

Printer/Scanner Icon

Hit open scanner

Hit scan button and open MP Navigator

Default printer last printer used (MP560) (Use USB cable to port and indicates on line)

Hit scan

Do selection as needed/required

I set the scan to go desktop to see immediately

  • This question has an accepted answer on it already. How is this improving upon that already-accepted answer?
    – Ian C.
    Dec 28, 2014 at 0:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .