1

I have the fn key set up as the Meta key for Emacs. But recently Mac OS (both 12.0.1 and 12.1) has started gobbling one or two combinations of fn plus a letter key: most notably, fn+N opens Notification Centre, even though I have no shortcut set up for ‘Show Notification Centre’ in System Preferences → Keyboard → Shortcuts → Mission Control. Since a lot of Emacs modes use M-n to mean ‘next’, this makes those shortcuts in Emacs unusable.

I never use the systemwide fn-shortcuts. How do I defang them completely?

1
  • Since this keyboard shortcut is undocumented, apparently unchangeable, and appears to conflict with the intent of the option provided in System Preferences, I have reported the issue to Apple with Feedback Assistant. Hopefully they will change this behaviour. Jan 3, 2022 at 9:52

1 Answer 1

0

I found out the same. I thought setting (ns-function-modifier 'control) in emacsforosx will overlap Monterey OS system fn binding but it's not that like with previous osx versions.

We'll see if there's some response from Apple.

2
  • I have worked around this for now by providing keyboard-macro alternatives to all the offending system keyboard shortcuts I could find with ⌥⇧ plus the letter in question gitlab.com/dpk/dotfiles/-/commit/… Feb 5, 2022 at 10:59
  • What worked for me: I installed Karabiner-Elements and in System Preferences / Keyboard / Modifier Keys set Global Key: Control for Karabiner DriverKit 1.6.0.
    – rahed h
    Feb 14, 2022 at 18:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .