1

I have a new M1 Mac Mini running the latest version of macOS Monterey.

I've connected it via Ethernet to a switch, using the native onboard Mac Mini Ethernet port. But the ethernet connection cuts out and drops connectivity every 20-30 seconds. The Wi-Fi connection does not have this problem.

If I leave System Preferences > Network open in the background, I see the Ethernet connection constantly dropping and reordering itself under Wi-Fi. After a few seconds, the Ethernet connection reconnects and again moves to the top of the list.

Ethernet losing connection on M1 Mac Mini

Ethernet Connected
Ethernet Not Connected

What is wrong with this Ethernet connection? Why is it dropping? How can I fix this issue and hopefully turn off Wi-Fi on this Mac?

Console app shows some potential logging related to this, although I'm not sure what I should be looking for:

kernel | AppleBCM5701Ethernet [en0]: Link down (womp disabled, proxy idle)

Springboard | -[NWSystemPathMonitor updateFlags] Wi-Fi primary: false->true, Ethernet primary: true->false, VPN active: false->false

UserEventAgent | Ethernet signature changed

5
  • And what have you tried? Replacing the network cable? A different switch port? When the Mac says the port has dropped, does the switch agree? Commented Dec 24, 2021 at 3:09
  • This is potentially the same issue. I'll try rebooting and see if it works prior to the first disconnect of the ethernet cable.
    – pkamb
    Commented Dec 24, 2021 at 3:33
  • I just updated to macOS 12.1 and restarted, keeping the ethernet cable plugged in. Still exhibits this issue upon restart.
    – pkamb
    Commented Dec 25, 2021 at 0:18
  • So, again, what have you tried? Commented Dec 25, 2021 at 1:32
  • I thought I started having this issue, it turned out one of my transceivers was a SFP plugged into a SFP+ port… oh networking how I love thee.
    – Marc
    Commented Nov 16, 2023 at 22:48

2 Answers 2

4

I ran into this same issue on a WiFi/Ethernet connection with my M1 Max Mac. The Wi-Fi and Ethernet conflicted with one another, and it has to do with how it renders IPv6 addressing on Monterey. My modem automatically refers to IPv6 in its DNS settings, so there was no need to have MacOS try to do its own.

There are two ways to fix this:

  1. Set IPv6 to local-addressing only. Click System Preferences > Network USB/Ethernet selected > Click the "Advanced" button. In "Configure IPv6:", change it to "Link-local only" or "Manually". Don't change any other settings by hitting OK, then Apply. It'll remove the additional settings it doesn't need. You might also want to turn off Wi-Fi when you're connected to Ethernet so the two don't conflict.

  2. You can also specify that the USB/Ethernet and Wi-Fi connections remain separate connections so they don't conflict with one another. (This is optional--step 1 should fix itself, but it adds additional fixes so the two connection types don't conflict.) You do this in the Network section of System Preferences, which explain it here: https://support.apple.com/en-us/HT202480

    Create two locations: One labeled "Wireless" and another labeled "Ethernet". Then, you remove the Wi-Fi connection out of the Wired location you create, and remove the Wired connection out of the Wi-Fi location. Then, when you need to change, click the Apple Menu, hover over "Location" and then click "Wireless" or "Ethernet" depending on your connection method.

2

had the same issue with a Mac mini m2.

intermittent ethernet drops. every 3 or 4 pings the connection would timeout.

I was able to solve my issue with these manual hardware settings:

100baseTX

half-duplex

AVB/EAV disabled

MTU 1500

ethernet settings

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .