1

With OS Monterey (MBP M1), after an app has been launched AND closed, its icon remains on the dock (without the "open indicator"). I can manually remove it, but how do I prevent app icons from being automatically added to the dock?

To clarify: What I'm asking isn't removing recent apps from showing up on the dock. (To remove recent apps from the dock, see the suggested post)

What I want is this: When an app-not part of the collection of apps on the dock-is opened, it appears on the dock with a separator that keeps it apart of the "regulars" on the dock. When I quit the said app, the icon disappears as well. That was how it worked for me until recently. Now, when I launch an app, its icon appears on the dock--and remains even after I quit the app. I have to manually remove it from the dock.

8
  • 1
    What have you tried so far? Did you have a look at the Dock's System Preferences at least?
    – Redarm
    Commented Dec 23, 2021 at 18:00
  • 1
    Show Recent Apps does not prevent active apps from showing. There are two things that will leave the app icon in the dock... the option described, and picking up the icon and moving it. If you move the icon while it is in the dock, it will always stay where you move it to, regardless of how the option is set. Commented Dec 23, 2021 at 19:28
  • 1
    @YCode What you are describing in your revised question still exactly describes the "Show recent applications in Dock" preference, where recently used applications that were quit remain to the right of a divider of other apps in the Dock stay there and can be either removed manually, or by unchecking mentioned preference. What exactly is the difference? Does the application remain there, even with the preference un-ticked?
    – Redarm
    Commented Dec 23, 2021 at 23:57
  • 1
    It also seems there also is a bug, where right after unchecking and rechecking said preference, the application will stay in the Dock to the left of the divider for recently used applications. Only a logout and login again will rectify that issue.
    – Redarm
    Commented Dec 24, 2021 at 0:10
  • 1
    @Redarm Yes, logging out and logging in again fixed it for me. Thanks!
    – YCode
    Commented Dec 24, 2021 at 16:09

1 Answer 1

5

Try going to System Preferences > Dock & Menu Bar > Uncheck "Show recent application in Dock".

1
  • Thanks for your response! I updated my question for clarification.
    – YCode
    Commented Dec 23, 2021 at 18:50

Not the answer you're looking for? Browse other questions tagged .