The last time I installed an OS update, I thought I could start the update, go away for a while, and it would be done when I returned. But when I got home I found it waiting for me to tell it to restart the computer to install the update, and then I had to wait for that to complete.

This weekend I plan on upgrading from Big Sur to Monterey (giving in to the nagging badge on the System Prefs dock icon), and I'm hoping there's a way to do what I tried. Is there a way to configure Software Update so that it will restart automatically instead of waiting for me to answer the prompt? That way I can start it, go to the gym, and (assuming the upgrade was successful) find the Mac ready to use when I return.

  • Minor updates and security patches can go in one step. Major upgrades can not. Why not do the download hours earlier while you work then start the upgrade when you’re ready to hit the gym?
    – bmike
    Sep 15, 2022 at 21:25
  • I seem to recall a Terminal command to download updates without installing. Can you remind me what it is? I can use this now for the 12.6 update.
    – Barmar
    Sep 15, 2022 at 21:30

2 Answers 2


From the command line (in Terminal.app or another app like iTerm), to pre-download updates:

softwareupdate -da

Once they are downloaded, to install

softwareupdate --no-scan -aiR

You can leave the R off if you don't want your Mac to automatically restart itself, so if the command complains about needing sudo run

sudo !!

I did the upgrade this morning, and it did restart automatically.

I did have to stick around while it was downloading the upgrade, because after the download it starts the upgrade application, which requires you to agree to the EULA, select the volume to install on, and click "Continue". But then I left for Zumba class, and when I returned it had rebooted and was sitting at the login prompt.

I ran into two glitches:

  1. The installer said I needed to set the volume as my boot volume. As I found out in this Apple Discussion Forum post, I should run the installer from an Admin account. Luckily, when I switched to the Admin account and started the upgrade over, it didn't need to re-download the installer (which had taken about 20 minutes -- better than the 35 minutes it estimated, but why doesn't it download this in the background when it first detects the upgrade is available?).

  2. When I logged in, it didn't immediately connect to the network properly. I have USB Ethernet via a J5create hub, and two local WiFi networks. Network Preferences showed one of the WiFis, but it didn't get an IP from it. I played around in preferences, adding back the USB Ethernet manually, switching to a public WiFi hotspot and back, and eventually everything connected properly. So I'm not sure what was going on there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .