3

I've recently updated my ipad's IOS to 15 but after that it will charge randomly or never when connected to the power.

Yesterday I've updated it again to IOS 15.2 but problem still exist.
I visited many sites for this problem and one of the options was to hard restart ipad. But as you know I must hard restart my ipad every time I want to charge it!

I changed cable and cleaned the port but nothing changes. This link shows I'm not alone with this problem after IOS 15.

Do anyone know permanent solution for this problem? I'm sure that my ipad's port or cable have not any problems and the problem is from last update.

UPDATE:
My device’s board was burnt! After the update:) So I changed the board and the problem has been solved

6
  • I tried network setup init . That seemed to help : after 15.2 I was limited to 80% charge, this seemed to do the trick so I could get full charge.
    – Ptit Xav
    Commented Dec 20, 2021 at 12:10
  • @PtitXav sorry but I cant understand . Can you explain more how to do network setup ?
    – Nameless
    Commented Jan 3, 2022 at 15:21
  • Sorry I was not precise : setting/general/reset network . Not sure the exact menu , because it changed a little in iOS 15.
    – Ptit Xav
    Commented Jan 3, 2022 at 16:34
  • @PtitXav I did that but unfortunately nothing changed
    – Nameless
    Commented Jan 8, 2022 at 13:10
  • Have you now tried iOS 15.5?
    – lhf
    Commented Jul 11, 2022 at 12:36

1 Answer 1

0

The device firmware manages charging so you should shut off the OS while it’s connected to power to see if it charges correctly when the OS is idle / off.

It’s super rare for iOS updates / upgrades to affect things, but you could use Apple Configurator 2 to do a restore of the device if you think somehow the firmware side could have been corrupted.

Most likely, the symptoms are coincidental to your software changes and not causal. I hope it’s an easy update or a restore solves it, but odds are it’s time for hardware service.

2
  • Yes! When I turn off my Ipad and then plug in my charger, my Ipad turns on and thats a sign that the problem is software based. I visited ipsw.me for restore but there is no SIGNED version less than IOS 15 in there.Moreover ,I cant find my ipad model in that website too(Ipad 6th generation)A1893. Can you help me in this case?
    – Nameless
    Commented Feb 11, 2022 at 3:41
  • 1
    So two things - I’m not good with researching the old OS versions, but you are 100% in the right place for that. Second, let me be clear - you have to plug in the power - let the iPad start and then turn it off - while keeping it connected. That will test a charge without the OS running.
    – bmike
    Commented Feb 11, 2022 at 4:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .