I have tried restoring through iTunes, but I only get "Error 37" at the end of the "Restoring iPad firmware" step.

Snippets from the restore log:

2012-03-11 18:00:05.684 [3132:e4]: <Restore Device 069D6950>: operation 18 progress 53
2012-03-11 18:00:05.884 [3132:e4]: <Restore Device 069D6950>: operation 18 progress 61
2012-03-11 18:00:06.169 [3132:e4]: <Restore Device 069D6950>: operation 18 progress 69
2012-03-11 18:00:06.535 [3132:e4]: <Restore Device 069D6950>: operation 18 progress 76
2012-03-11 18:00:06.821 [3132:e4]: <Restore Device 069D6950>: operation 18 progress 84
2012-03-11 18:00:09.037 [3132:e4]: device returned AMR error 37

(It fails at 84% "restoring firmware" each time)


entering update_device_firmware
entering update_iBoot
write_image3_data: flashing LLB data (length = 0x14a19)
AppleImage3NORAccess::_getSuperBlock imageVersion: 3
AppleImage3NORAccess::_getSuperBlock imageVersion: 3
write_image3_data: flashing NOR data (length = 0xb10)
ticket updated
write_image3_data: flashing NOR data (length = 0x2ea19)
write_image3_data: flashing NOR data (length = 0xf859)
write_image3_data: flashing NOR data (length = 0x1d59)
write_image3_data: flashing NOR data (length = 0xb999)
write_image3_data: flashing NOR data (length = 0x4519)
write_image3_data: flashing NOR data (length = 0x1819)
write_image3_data: flashing NOR data (length = 0x13d9)
write_image3_data: flashing NOR data (length = 0x3e59)
write_image3_data: flashing NOR data (length = 0x13d9)
write_image3_data: flashing NOR data (length = 0x3cf19)
0: RamrodErrorDomain/3e9: update_iBoot: error writing image
1: NSMachErrorDomain/e00002bc: write_image3_data: AppleImage3NORAccess returned an error when writing image3 object
attempting to dump restore log
writing log file: /mnt1/restore.log

I have tried pretty much everything:

  • Different computers (both mac and win7)
  • Different usb-cables
  • Re-downloading the ipsw
  • Re-installing iTunes
  • Removing every playlist/book/movie from my iTunes library
  • Disabling auto-sync of devices in iTunes

The documentation for "error 37" indicates problems with security software (which I'm not running), and judging by the restore log this looks like more a bug in the updater/firmware itself.

The iPad was running fine with iOS 5.0.1 and has never been jailbroken.

1 Answer 1


This suggests that your NOR is failing/has failed. It could be a communications error also, but strange it gets so far before failing if it is a comms error.

Almost certainly this is hardware. If you still have extended warranty, use that. Otherwise you need to get this replaced via Apple's out of warranty program. I'm not sure any third party hardware repair place could fix this, they would need to copy the unique data that is stored in another part of your NOR chip to a good NOR chip. This unique data is encrypted and I don't know if it can actually be copied successfully.

source: http://www.hackint0sh.org/f131/212842.htm

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .