2

I just bought a MacBook Air and a cheap Leadership USB optical mouse, which I can't get to work with the MacBook. It works fine with Windows and Linux, and the Macbook Air USB ports are fine. I checked it with USB drive and a Microsoft mouse without encountering any problems.

What can I do to solve the problem?

1 Answer 1

2

If it supports the standard USB mouse functionality (HID), it should work. Otherwise, you can use SteerMouse or USB Overdrive. If you have the Developer Tools installed, you might also see what USB Prober says about the device.

3
  • Those two are what I am looking for but I as expecting I shouldn't need to buy extra software to just plug an standard usb mouse. Mar 12, 2012 at 11:04
  • @JhonnyEverson that means it's either not a standard USB mouse, or something is amiss. Try USB Prober.
    – David
    Mar 12, 2012 at 19:19
  • Looking at System Profiler, it shows 'Optical Mouse Device' on USB port but does not work. I installed SteerMouse and it's working fine now. Thanks for your suggestions. PS. I tried 4 usb mouses from different brands before installing that. The only one that worked as MS'. Mar 13, 2012 at 2:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .