I messed up -- and followed some internet advice a few days ago without totally understanding the ramifications. Specifically, in trying to stop the Finder from asking me to verify every time I wanted it to move or delete a file, I went to my home directory, looked at its permissions in Info (Read/Write for me, Read Only for Staff and Everyone), thought that looked like what I wanted everywhere, so I then selected "Apply to Enclosed Items".

I've recently realized that I probably shouldn't have done this, as various things have begun failing at an accelerating clip. Yesterday, iTunes refused to back up my iPhone and iPads; and ClipMenu started reporting that it can no longer save my clipboard history (not a huge problem, but a good example). Today many of my preferences no longer work, and I can't set/save them (e.g., Mail "forgot" my password and can't seem to remember it when I set it, Finder preferences don't stick, etc.).

So ... is there a way to reset the various file and group permissions back to their original settings? I've tried Disk Utility -> Verify (and Repair) Disk Permissions, followed by restarts, to no avail. Note that I'm obviously not a guru and not nearly as smart as I'd hoped, so any help you can give probably needs to be "dumbed down" a little.

Thanks, Ed

P.S. BTW, in regards to preference problems, one message I get is 'Group differs on “Library/Preferences/com.apple.alf.plist”; should be 80; group is 0.', which goes away after the repair, but comes back again after I've tried (and failed) to change a preference.

--- EDIT ---

The "problem"may not be permission-related at all, but a corrupted keychain!

I used the Keychain Access utility to verify and then repair (eventually, after several attempts) the keychain, and all of the symptoms seem to have disappeared, for now. I don't pretend to understand any of this, but I'm glad it seems OK now.

Thanks to all for their patient and thoughtful replies.

2 Answers 2


If I understand your question correctly, you're attempting to reset the permissions on a user's home directory. This is easily accomplished by resetting ACLs on the desired home directly by using the Reset Password Utility in the Recovery Partition:

  1. Restart your computer from the recovery partition (if running Lion) or the gray disk (if not running Lion).

  2. Open Disk Utility and run a permissions repair on your startup volume. After this is complete, close Disk Utility. We're doing this just for good measure.

  3. Open Terminal from the Utilities menu. Type in resetpassword and select your user account (NOT System Administrator/root) from the drop down menu.

  4. Click the Reset button at the bottom of the window in the Reset home folder permissions and ACLs section.

  5. Quit the Password Utility and go back to the main recovery screen.

  6. On your keyboard, hit + Q and restart your computer. It's very important that you don't hold down the power button to exit the recovery session, or the ACL reset won't occur.

Good luck!


Have you backed up your home folder via Time Machine or other back up method? If so, you could try restoring your home folder to its previous state that way. Another possible solution, though less likely to work but definitely worth a try, is to go back into your Home folder's info window. Access that same drop down menu you used to apply changes to enclosing items, and you'll see an item that reads "Revert changes." If it's grayed out (like in the photo below) then no dice. If it's not grayed out you may be able to restore the permissions this way. Again, a long shot but worth a try before you resort to backups.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .