3

macOS Big Sur (11.6.1) on a late-2013 MacBook Air.

iOS 15.1 on an iPhone SE (1st generation)

AirDrop works from the MBA to the iPhone, but not from the iPhone to MBA. When trying to send a photo from the iPhone to the MBA, the MBA appears on the iPhone as an AirDrop destination (i.e., the MBA is "seen" or "discovered"). When selected, the MBA icon shows "Waiting," but the transmission doesn't occur.

In the opposite direction (MBA > iPhone) AirDrop works correctly. Both the MBA and iPhone connect and operate correctly, and both are connected to the same wifi network. Bluetooth is enabled on both, and on the MBA sudo pkill blued has been run in the Terminal, and /Library/Preferences/com.Apple.Bluetooth.plist has been trashed (and automatically recreated).

Until last week, AirDrop worked bidirectionally, as it has on these two devices for years. I cannot identify a specific update (on either the MBA or the iPhone) after which AirDrop failed.

I've restarted both machines, force-restated the iPhone, and signed out of iCloud and then in again on both. No change is noted.

What else might I try?

0

1 Answer 1

2

I was able to solve this problem by turning OFF the Firewall in the MBA.

Together with the VPN that may be stopping Airdrop, also the Mac Firewall turned ON can be the reason for this problem.

By turning it OFF for a moment it is possible to make Airdrop work (at least in my case). This can be configured in System Preference > Security & Privacy > Firewall > Turn Off Firewall.

Alternatively, instead of turning Firewall OFF you can just allow incoming connection for the sharingd service.

2
  • On the MBA, I navigated System Preferences > Security & Privacy > Firewall > Firewall Options and found that sharingd was set to "Block Incoming Connections." Reset to "allow," and AirDrop works correctly. Thanks very much, this solved the issue. Dec 30, 2021 at 16:21
  • @DavidSupportsMonica I am glad to hear that. If this is the case, you should mark my response as solution to the problem ;-)
    – rebatoma
    Dec 30, 2021 at 22:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .