2

Every time I open my Mac in the morning, I see the notification on my macOS Lock Screen:

Sleep Off Notification

Sleep
Off

When I get home from the gym and open my Mac, I see

Fitness
Off

How can I hide this notification? Either completely, or, especially, hide it from the lock screen?

System Preferences > Notifications & Focus > Notifications does not have an app section for "Focus" or "Sleep". I cannot find the app to uncheck the normal "Show notifications on lock screen" option.

The Focus tab does not seem to have any controls to control notifications for Focus modes.

This is the new Focus feature in macOS 12 Monterey.

3
  • What version of macOS? Dec 8, 2021 at 12:50
  • @SteveChambers Monterey
    – pkamb
    Dec 8, 2021 at 16:06
  • 1
    @pkamb Thanks for this question... On my first morning of Monterey I see the same issue. Not only can I find no way to disable the these, but the behavior is different from iOS devices which don't (usually) display previous Focus state changes. Dec 31, 2021 at 14:51

1 Answer 1

3

In the focus tab you can unselect Share Across Devices and then disable focus on the Mac completely. Seems to be the only way to “switch off” the notifications. It’s crazy that they forgot to add the option to hide the notification on a feature which is supposed to help you focussing.

On the other hand, focus on the Mac is unnecessary for me I’ve switched of most notifications anyway, so nothing lost.

1
  • 1
    Thanks for your answer @Ferio. Agree completely: seems crazy that Apple shipped this silly behavior. I imagine the root cause is differences in either the Notification framework or Sleep states between macOS and iOS. Recommend: apple.com/feedback Dec 31, 2021 at 14:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .